Results 1 to 6 of 6

Thread: Architect extenstion doesn't work well in design view

    Success! Looks like we've fixed this one. According to our records the fix was applied for DSGNR-7669 in Architect 4.2.
  1. #1
    Sencha Premium Member ragzovskii's Avatar
    Join Date
    Sep 2012
    Location
    Krasnoyarsk, Russia
    Posts
    242

    Default Architect extenstion doesn't work well in design view

    Hello.
    After recent updgrade to SA 4.1.2 we noticed, that our extension, that renders special component, is not visible in design view. There is only 1 error message in log saying: 'Framework error: Cannot read property model of undefined'. There are two stores in project inspector, both showing error and message 'there was an error creating your store. please verify configuration'. Unfortunately, no details are given.
    When we preview app from SA, it works fine, stores are created successfully, it is only design view that brings us troubles. What could be the issue here?
    Capture.jpg

  2. #2
    Sencha User
    Join Date
    Sep 2014
    Location
    Central Europe
    Posts
    795

    Default

    HI

    Unfortunately without the extension there is not much we could do. Would you be able to send it to architect.feedback [at ]sencha.com ? Please link there this thread. Or you can create support ticket with attachment and tell there to be redirected to the engineering. Please let me know here if you are able to send it / way you sent it.

    Or if you are not able to send, could you share the code of your store?

    Btw was this update from 4.1.1 to 4.1.2 ? Because according to the changelog there shouldn't be anything which would cause such issue

    Thank you
    Petr

  3. #3
    Sencha Premium Member ragzovskii's Avatar
    Join Date
    Sep 2012
    Location
    Krasnoyarsk, Russia
    Posts
    242

    Default

    Hello.
    I sent you email with attachment, topic "extension issues after upgrade to 4.1.2".
    Is there a way to get more detailed error description from architect?
    Thank you

  4. #4
    Sencha User
    Join Date
    Sep 2014
    Location
    Central Europe
    Posts
    795

    Default

    Hi

    Could you please re-send the archive? Nothing has reached us. Gmail is sometimes marking these emails (with this attachment) as spam ...
    Could you perhaps upload it to google drive / dropbox (or any site you like) and send just link ? It might be quicker if you send the link also to me here on the forums as PM.

    Is there a way to get more detailed error description from architect?

    I am afraid that currently there is no way to get more detailed error info from the stable build.

    Thank you
    Petr

  5. #5
    Sencha Premium Member ragzovskii's Avatar
    Join Date
    Sep 2012
    Location
    Krasnoyarsk, Russia
    Posts
    242

    Default

    Hello.
    I sent you link to PM.
    Thank you.

  6. #6
    Sencha User
    Join Date
    Sep 2014
    Location
    Central Europe
    Posts
    795

    Default

    Hi

    I can confirm the issue. This is blocker and top priority for next release.
    There is an issue with registering the models and probably their extend config.

    But I think the problem is just in the design view of the SA? So users can still use it without the design view of the class, just click on some other view class and press Refresh button, the other views should load fine.

    Workaround would be to define the models outside of the extension but I guess that would be really lot of work other than that just stick with 4.1.1

    I am sorry for the troubles
    Petr

Similar Threads

  1. Architect fails to open design view
    By bwmatthews in forum Sencha Architect 3.x: Bugs
    Replies: 0
    Last Post: 26 Feb 2015, 11:35 AM
  2. [INFOREQ] Sencha Architect - Design View Error
    By dhanashree in forum Sencha Architect 3.x: Bugs
    Replies: 1
    Last Post: 11 Feb 2014, 5:01 PM
  3. [OPEN] Architect design view shows nothing
    By grizzly21 in forum Sencha Architect 2.x: Bugs
    Replies: 3
    Last Post: 20 Dec 2013, 10:14 AM
  4. Sencha Architect Design View goes blind when...
    By TEZCATLIPOCA in forum Sencha Architect 2.x: Bugs
    Replies: 1
    Last Post: 7 Dec 2012, 10:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •