Results 1 to 6 of 6

Thread: app build is failing in 6.5 after upgrade

  1. #1
    Sencha User
    Join Date
    Sep 2015
    Posts
    44
    Answers
    4

    Default app build is failing in 6.5 after upgrade

    Hello,

    I'm getting this error within Sencha ext framework. when I do sencha app build --fashion-symbols.

    [LOG] Fashion Error : map.get is not a function :
    [LOG] at /[app_path]/ext/modern/theme-neptune/sass/var/Button.scss:1519
    [LOG] at /[app_path]/ext/modern/theme-neptune/sass/var/Button.scss:1574
    [ERR]
    [ERR] BUILD FAILED
    [ERR] com.sencha.exceptions.ExBuild: Fashion build exited with code : 1
    [ERR] at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ
    [ERR] e Method)

    It's failing inside theme-neptune which is part of 6.5 framework I upgraded. Is this bug in the framework or am I missing something?

    Thanks,


  2. #2
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985
    Answers
    506

    Default

    I haven't yet seen a report of this but the release was just yesterday. Have made many customizations to the Neptune theme? What order did you upgrade Cmd and Ext JS?

  3. #3
    Sencha User dongryphon's Avatar
    Join Date
    Jul 2009
    Location
    Kansas
    Posts
    1,748
    Answers
    55

    Default

    That method is new to Cmd 6.5 so it sounds like you have Cmd < 6.5?
    Don Griffin

    "Use the source, Luke!"

  4. #4
    Sencha User
    Join Date
    Sep 2015
    Posts
    44
    Answers
    4

    Default

    Quote Originally Posted by dongryphon View Post
    That method is new to Cmd 6.5 so it sounds like you have Cmd < 6.5?

    So, I have a custom theme that I partly generated through Sencha Themer. And some theme I customized on top of Themer. Now that I updated to Sencha Cmd 6.5 #180 and ext framework to 6.5, it throws this error when I build my modern app.

    However, if I generate a new theme then it works fine but I'd rather not have to redo the entire theme. Any thoughts on upgrading the theme or a method to debug this? I tried
    Code:
    sencha package upgrade
    but that didn't work

  5. #5
    Sencha Premium User
    Join Date
    Jun 2017
    Posts
    1

    Default

    I am having the same problem with the latest stable release cmd 6.5.1 and ext 6.5.1. I upgraded the packages as well but the result is the same build error. Did you get it resolved?

    Quote Originally Posted by udayp View Post
    So, I have a custom theme that I partly generated through Sencha Themer. And some theme I customized on top of Themer. Now that I updated to Sencha Cmd 6.5 #180 and ext framework to 6.5, it throws this error when I build my modern app.

    However, if I generate a new theme then it works fine but I'd rather not have to redo the entire theme. Any thoughts on upgrading the theme or a method to debug this? I tried
    Code:
    sencha package upgrade
    but that didn't work

  6. #6
    Sencha User
    Join Date
    Sep 2015
    Posts
    44
    Answers
    4

    Default

    No. I decided to hold off moving to 6.5 and went with 6.2.1 to production. Planning to migrate in August but I feel like I need to rewrite the theme for 6.5.x.

    Also, I haven't tried with 6.5.1 yet.
    Last edited by udayp; 27 Jul 2017 at 12:34 PM. Reason: clarification of version

Similar Threads

  1. Build and upgrade are both failing
    By NathanKerr in forum Sencha Cmd
    Replies: 5
    Last Post: 6 Jan 2016, 6:59 AM
  2. Upgrade from Ext JS 4.1 to 5.0 failing
    By noiks in forum Sencha Cmd
    Replies: 1
    Last Post: 2 Apr 2015, 5:43 AM
  3. sencha app upgrade failing
    By pbienick in forum Sencha Cmd
    Replies: 6
    Last Post: 30 Jan 2013, 4:53 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •