Results 1 to 4 of 4

Thread: Is Sencha CMD 6 compatible with EXTJS 5.x Projects?

  1. #1
    Sencha User Carlos Souza's Avatar
    Join Date
    May 2015
    Location
    Minas Gerais, Brazil.
    Posts
    29

    Default Is Sencha CMD 6 compatible with EXTJS 5.x Projects?

    Hi,

    Is Sencha CMD 6 compatible with EXTJS 5 projects? If it is not compatible, is there any way to use both cmds (5 and 6) on the same Windows PC?

  2. #2
    Sencha User Carlos Souza's Avatar
    Join Date
    May 2015
    Location
    Minas Gerais, Brazil.
    Posts
    29

    Default

    Anyone?

  3. #3
    Sencha User
    Join Date
    Sep 2014
    Location
    Central Europe
    Posts
    795

    Default

    Yes it's compatible. Both Cmd 6.2 and Cmd 6.5 should be compatible witch ExtJS 5

    You can always install multiple versions of Sencha Cmd on the computer. But you can have only one in the path (in the terminal) but you can always execute the second directly from the executable or create another path with different name.

    Also Sencha Cmd 6.x provides nice command sencha switch where you can switch the version on the fly.

    Code:
    > sencha switch --list                                 
    Sencha Cmd 6.5.0.180                                   
    Looking for versions at: C:\Users\Petr\bin\Sencha\Cmd  
                                                           
    Current version                                        
       6.5.0.180                                           
                                                           
    Newest version installed                               
       6.5.0.180                                           
                                                           
    Locally available versions                             
       5.0.2.270                                           
       5.0.3.324                                           
       5.1.3.61                                            
       6.0.2.14                                            
       6.1.1.76                                            
       6.1.2.15                                            
       6.1.3.42                                            
       6.2.0.68                                            
       6.2.0.73                                            
       6.2.0.75                                            
       6.2.0.78                                            
       6.2.0.103                                           
       6.2.1.29                                            
       6.2.2.23                                            
       6.5.0.168                                           
       6.5.0.176                                           
       6.5.0.180
    Code:
    > sencha switch 6.2.0.103
    Sencha Cmd 6.2.0.103
    
    
    Successfully switched to version 6.2.0.103
    Regards
    Petr

  4. #4
    Sencha User Carlos Souza's Avatar
    Join Date
    May 2015
    Location
    Minas Gerais, Brazil.
    Posts
    29

    Default

    Quote Originally Posted by petr.vecera View Post
    Yes it's compatible. Both Cmd 6.2 and Cmd 6.5 should be compatible witch ExtJS 5

    You can always install multiple versions of Sencha Cmd on the computer. But you can have only one in the path (in the terminal) but you can always execute the second directly from the executable or create another path with different name.

    Also Sencha Cmd 6.x provides nice command sencha switch where you can switch the version on the fly.

    Code:
    > sencha switch --list                                 
    Sencha Cmd 6.5.0.180                                   
    Looking for versions at: C:\Users\Petr\bin\Sencha\Cmd  
                                                           
    Current version                                        
       6.5.0.180                                           
                                                           
    Newest version installed                               
       6.5.0.180                                           
                                                           
    Locally available versions                             
       5.0.2.270                                           
       5.0.3.324                                           
       5.1.3.61                                            
       6.0.2.14                                            
       6.1.1.76                                            
       6.1.2.15                                            
       6.1.3.42                                            
       6.2.0.68                                            
       6.2.0.73                                            
       6.2.0.75                                            
       6.2.0.78                                            
       6.2.0.103                                           
       6.2.1.29                                            
       6.2.2.23                                            
       6.5.0.168                                           
       6.5.0.176                                           
       6.5.0.180
    Code:
    > sencha switch 6.2.0.103
    Sencha Cmd 6.2.0.103
    
    
    Successfully switched to version 6.2.0.103
    Regards
    Petr
    Wow! That's great!

Similar Threads

  1. Is ExtJS 6 not compatible with IE any more?
    By Str in forum Ext JS 6.x Q&A
    Replies: 2
    Last Post: 23 Jul 2015, 1:44 PM
  2. Replies: 2
    Last Post: 9 Oct 2014, 8:15 AM
  3. Sencha 4.1.0 is not compatible with IE9/10
    By venkat006 in forum Ext: Discussion
    Replies: 3
    Last Post: 8 Nov 2013, 2:55 PM
  4. sencha charts 2 are compatible with sencha touch 2 commercial free?
    By chandu_munna in forum Sencha Touch 2.x: Q&A
    Replies: 1
    Last Post: 26 Feb 2013, 3:14 AM
  5. Sharing code between ExTJS 4 and sencha projects
    By jacob.andresen in forum Community Discussion
    Replies: 5
    Last Post: 18 Oct 2011, 5:42 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •