Results 1 to 5 of 5

Thread: How to open the Sencha studio Chrome browser in security disabled mode .

  1. #1

    Default How to open the Sencha studio Chrome browser in security disabled mode .

    Hi Everybody,

    I have an application which needs an extension of CORS in Chrome and which runs fine when opened in Chrome with corss extension.

    When i import my project in sencha test studio and run through embeded browser i found that my application is not running because web security is not disabled for Chrome or CORS extension is not added to the browser same with the local broswer as well.

    It will be a great help if some would let me know how to open the Sencha Studio browsers (Chrome) in security disabled mode .


  2. #2
    Sencha - Test Dev Team marcelofarias's Avatar
    Join Date
    Nov 2011
    Boca Raton, FL


    WebDriver scenarios:

    • Install and start a Selenium standalone server. You can do that using the selenium-standalone npm module:

    npm install -g selenium-standalone
    selenium-standalone install
    selenium-standalone start
    • Alternatively, you can just use the Embedded farm, which listens by default on port 4450 (remember to start it manually by clicking on the power button).
    • Create a new browser farm - host: localhost, port: 4444 (selenium standalone) or 4450 (embedded farm).
    • In the new farm, add a browser pool (take note where you will save the pool definition file - you will need it later).
    • Add Chrome to the browser pool and save it.
    • Open the pool definition file (it's a JSON file, named after the pool, in the directory you selected before).
    • Edit the Chrome entry to add the command line argument to disable web security:

            "browserName": "chrome",
            "chromeOptions": {
                "args": [ "disable-web-security" ]
            "sencha": {
                "concurrency": 1
    • Restart Sencha Test Studio (since you manually edited the pool definition).
    • Select Chrome from the new pool to run your tests.

    In-browser scenarios:

    • Start a new Chrome instance with web security disabled using the following command line:

    "/Applications/Google Chrome" --disable-web-security --user-data-dir=/var/tmp/chrome --test-type http://localhost:8800
    • The new instance will point to the parking lot (localhost, port 8800 by default)
    • Select Chrome from the list of local browsers and the parked instance will be used by Sencha Test Studio.
    • Note that the paths above are valid for Mac OS X - adjust them if you're using Windows or Linux.

    Marcelo Bukowski de Farias

  3. #3


    Thanks a lot.

  4. #4
    Sencha User
    Join Date
    Mar 2017


    Can someone provide a few more examples on how to use chromeOptions within the ST browser pool configurations? Specifically around setting timeout values. I'm receiving the following error when running my Chrome 76 chromedriver browser.

    [ERROR] [model/browser/SandboxBrowser-20] [ERROR] [orion] Error: A script did not complete before its timeout expired. at execute("var a = arguments; return window.___stcache && ___stcache.f0 ? ___stcache.f0.apply(null, a) : { isCacheMiss: true } ") - C:\Program Files\Sencha\Test\2_2_1_83\resources\app.asar\node_modules\orion-core\serve\context\WebDriver.js:285:35

  5. #5
    Sencha User
    Join Date
    Mar 2017


    Bump. The timeout error is not observed on the latest build of ST BUT that version won't actually execute my tests. It just launches chrome 76 browser (without timing out like all previous versions) and silently fails to execute all my tests. The embedded chrome browser fails in the same way.

Similar Threads

  1. Replies: 6
    Last Post: 21 Feb 2018, 5:07 AM
  2. [OPEN] Sencha Studio(Test): Event Recorder, opaque overlay Chrome
    By JamesHounshellAPIvista in forum Bugs
    Replies: 5
    Last Post: 14 Nov 2017, 8:10 AM
  3. Replies: 2
    Last Post: 1 Mar 2016, 7:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts