Results 1 to 4 of 4

Thread: Errors in Minified JS libraries after upgrade to 6.5

  1. #1
    Sencha Premium Member
    Join Date
    Jun 2010
    Posts
    36
    Answers
    3

    Default Answered: Errors in Minified JS libraries after upgrade to 6.5

    I'm including some extra JS libraries via app.json, (D3.js and TinyMCE.js, both minified). Everything was working just fine until I upgraded both ExtJS and CMD to 6.5. Now I'm receiving the following errors
    minified-errors.PNG

    Below is a snippet from my app.json showing how I include the files

    Code:
        "js": [
            /*
            {
                "path": "${framework.dir}/build/ext-all-debug.js"
            },
            */
            {
                "path": "app.js",
                "bundle": true
            },{
                "path":"resources/js/pagedown/Markdown.Converter.js"
            },{
                "path":"resources/js/tinymce/tinymce.min.js"
            },{
                "path":"resources/js/leaflet/leaflet.js"
            },{
                "path":"resources/js/awesome-markers/leaflet.awesome-markers.min.js"
            },{
                "path":"resources/js/d3/4.4.1/d3.min.js"
            },{
                "path":"resources/js/wicket/wicket.js"
            },{
                "path":"resources/js/wicket/wicket-leaflet.js"
            }
        ],
    Has anyone else experienced this or something similar? If I change the d3 library to the non-minified version, it works fine. So I'm really not sure what's going on here.

    EDIT:
    I just noticed that if I set "includeInBundle:true" on the d3 library, I then get the following errors during build

    build-errors.PNG

  2. Unfortunately this is a bug (SDKTOOLS-1841) in Cmd. It's been fixed for 6.5.1.

  3. #2
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985
    Answers
    506

    Default

    Unfortunately this is a bug (SDKTOOLS-1841) in Cmd. It's been fixed for 6.5.1.

  4. #3
    Sencha Premium Member
    Join Date
    Jun 2010
    Posts
    36
    Answers
    3

    Default

    Thanks Gary.

    Is 6.5.1 available for download yet?

  5. #4
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985
    Answers
    506

    Default

    Cmd 6.5.1 has not been released yet, but you should be able to download a nightly from the Support portal which you can use to test if it will fix this for you.

Similar Threads

  1. Upgrade to 6.2.0 from 6.0.1 Errors Out Due to all.scss
    By skoldrh in forum Ext JS 6.x Q&A
    Replies: 9
    Last Post: 19 Oct 2016, 2:57 PM
  2. Replies: 1
    Last Post: 30 Dec 2014, 2:18 PM
  3. upgrade command errors
    By chrisfarrell in forum Sencha Cmd
    Replies: 5
    Last Post: 15 Nov 2012, 3:36 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •