Results 1 to 4 of 4

Thread: Ext 6.5 -Unable to build app using package having modern component

  1. #1

    Default Ext 6.5 -Unable to build app using package having modern component

    I'm having trouble building app with ext 6.5 for Modern toolkit. I have created new Package called ModernP and have Created one custom component extending Ext.filed.ComboBox, this same component I am using in my app and now ext cmd throwing error in package source code.

    Here is file in package
    [CODE]
    Code:
    Ext.define("ModernP.form.field.ComboBox", {
        extend: 'Ext.field.ComboBox',
        xtype: 'ordpt-combo',
        onListRefresh: function(){       // console.log("onListRefresh");
        }
    });


    Here's what I have in app.json.
    [CODE]
    Code:
    "modern": {
                "toolkit": "modern",
    
    
                "theme": "theme-triton",
    
    
                "sass": {
                    "generated": {
                        "var": "modern/sass/save.scss",
                        "src": "modern/sass/save"
                    }
                },
                "requires": [
                    "ModernP"
                ]
            }


    But every time I tried to build the app I got following error

    Code:
    
    
    Code:
    [CODE]Sencha Cmd v6.5.0.180
    [INF] Processing Build Descriptor : modern (production environment)
    [INF] Loading compiler context
    [INF] Loading app json manifest...
    [ERR] Failed to resolve dependency Ext.field.ComboBox for file ModernP.form.field.ComboBox
    [ERR]
    [ERR] BUILD FAILED
    [ERR] com.sencha.exceptions.ExNotFound: Unknown definition for dependency : Ext.field.ComboBox
    [ERR]
    [ERR] Total time: 8 seconds
    [ERR] The following error occurred while executing this line:
    /Users/siddharthgujrathi/bin/Sencha/Cmd/6.5.0.180/ant/build/app/build-impl.xml:387: The following error occurred while executing this line:
    /Users/sid/bin/Sencha/Cmd/6.5.0.180/ant/build/app/init-impl.xml:408: com.sencha.exceptions.ExNotFound: Unknown definition for dependency : Ext.field.ComboBox
    This same problem is occurring when I am trying to extend Ext.dialog, Ext.field.Date.

  2. #2
    Sencha - Support Team bjdurham85's Avatar
    Join Date
    Mar 2014
    Posts
    962
    Answers
    55

    Default

    Hi--,

    Thanks for the info so far. It looks like the command you're running might have been cut-off but you're using "sencha app build production modern" correct?

    Also, is the ModernP package just for the modern toolkit? **You might check to see if it has the toolkit config defined in the app.json, if no try adding it ("toolkit" : "modern") and then the build again.

    Best!
    Bryan

  3. #3
    Sencha Premium User
    Join Date
    Nov 2012
    Posts
    25

    Default

    I'm having the same problem, although in my case I'm trying to extend the viewport.

    I think everything else is also the same as siddharth-arvan:

    1. I'm using Ext 6.5, Cmd v6.5.0.180, and an app created with the "modern" toolkit. (sencha app init [email protected] --modern TestApplication)
    2. I've added a new package and am trying to define a component in the package that extends Ext.container.Viewport
    3. Error message is the same:

    Code:
    [ERR] BUILD FAILED
    [ERR] com.sencha.exceptions.ExNotFound: Unknown definition for dependency : Ext.container.Viewport
    I didn't have any luck using the command mentioned above.

  4. #4

    Default

    I have the same issue, as I wanted to package a common menu system to include in several apps. I had "ExNotFound" error for 'Ext.Toolbar'

Similar Threads

  1. Replies: 3
    Last Post: 6 Oct 2016, 8:28 AM
  2. Replies: 1
    Last Post: 23 Sep 2015, 11:54 AM
  3. [INFOREQ] SA 3.0.1.1343 unable to build package: Requires JRE while JDK installed
    By cdt in forum Sencha Architect 3.x: Bugs
    Replies: 30
    Last Post: 13 Jun 2014, 7:46 AM
  4. Ubuntu 12.04 - Unable to build package
    By tend in forum Sencha Touch 2.x: Q&A
    Replies: 5
    Last Post: 1 Jun 2012, 1:01 AM
  5. Unable to Package in Sencha Architect 2.0 build 412 on both Vista and Ubuntu
    By rgratwick in forum Sencha Architect 2.x: Bugs
    Replies: 2
    Last Post: 3 May 2012, 1:07 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •