Results 1 to 5 of 5

Thread: Problem installing v4.2

  1. #1
    Sencha Premium Member
    Join Date
    Feb 2012
    Location
    Hillsborough, NC
    Posts
    447
    Answers
    3

    Default Problem installing v4.2

    I installed v4.2.1 of Architect to see if I wanted to upgrade from v3.

    It will not run on Ubuntu 14.04.

    Code:
    Error: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /opt/sencha/Sencha Architect 4.2/resources/app.asar.unpacked/vendor/nodejs/native/zip.node)
    Did I do something wrong?? Is Ubuntu 14.04 not supported?

  2. #2
    Sencha User
    Join Date
    Sep 2014
    Location
    Central Europe
    Posts
    795
    Answers
    103

    Default

    It looks like you have outdated libraries on your system.

    Try this:

    Code:
    sudo apt-get update
    sudo apt-get install libstdc++6

    FYI: SA 4 runs on all major Linux distributions but as usually on Linux you might need to install the missing libraries and their versions as each distro might include different version.

  3. #3
    Sencha Premium Member
    Join Date
    Feb 2012
    Location
    Hillsborough, NC
    Posts
    447
    Answers
    3

    Default

    Quote Originally Posted by petr.vecera View Post
    It looks like you have outdated libraries on your system.

    Try this:

    Code:
    sudo apt-get update
    sudo apt-get install libstdc++6

    FYI: SA 4 runs on all major Linux distributions but as usually on Linux you might need to install the missing libraries and their versions as each distro might include different version.
    Library already is installed and up to date.

    Code:
    [email protected]:~$ apt-show-versions libstdc++6
    libstdc++6:amd64/trusty-security 4.8.4-2ubuntu1~14.04.3 uptodate
    But I tried your suggestion anyway...

    Code:
    ...
    Ign http://us.archive.ubuntu.com trusty/multiverse Translation-en_US
    Ign http://us.archive.ubuntu.com trusty/restricted Translation-en_US
    Ign http://us.archive.ubuntu.com trusty/universe Translation-en_US
    Reading package lists... Done                
    [email protected]:~$ sudo apt-get install libstdc++6
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    libstdc++6 is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    I saw this command suggested on Google:
    Code:
    [email protected]:~$ strings /usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep GLIBCXX
    GLIBCXX_3.4
    GLIBCXX_3.4.1
    GLIBCXX_3.4.2
    GLIBCXX_3.4.3
    GLIBCXX_3.4.4
    GLIBCXX_3.4.5
    GLIBCXX_3.4.6
    GLIBCXX_3.4.7
    GLIBCXX_3.4.8
    GLIBCXX_3.4.9
    GLIBCXX_3.4.10
    GLIBCXX_3.4.11
    GLIBCXX_3.4.12
    GLIBCXX_3.4.13
    GLIBCXX_3.4.14
    GLIBCXX_3.4.15
    GLIBCXX_3.4.16
    GLIBCXX_3.4.17
    GLIBCXX_3.4.18
    GLIBCXX_3.4.19
    GLIBCXX_DEBUG_MESSAGE_LENGTH
    [email protected]:~$
    I don't know what it means but 'GLIBCXX_3.4.20' is not listed. Does that mean that Architect is using something that is not available on Ubuntu 14.04 LTS?

  4. #4
    Sencha User
    Join Date
    Sep 2014
    Location
    Central Europe
    Posts
    795
    Answers
    103

    Default

    Hm I would probably do this https://askubuntu.com/a/582910 it looks like the version 20 is missing in the default repo for 14.04

  5. #5
    Sencha Premium Member
    Join Date
    Feb 2012
    Location
    Hillsborough, NC
    Posts
    447
    Answers
    3

    Default

    Quote Originally Posted by petr.vecera View Post
    Hm I would probably do this https://askubuntu.com/a/582910 it looks like the version 20 is missing in the default repo for 14.04
    OK, that did it.

    Thanks

Similar Threads

  1. Installing problem with Architect 2.2
    By kaustbj in forum Sencha Architect 2.x: Help & Discussions
    Replies: 26
    Last Post: 14 Jul 2013, 6:47 PM
  2. Problem Installing Sencha Eclipse Plugin
    By chrismaka99 in forum Ext:User Extensions and Plugins
    Replies: 3
    Last Post: 9 Jul 2013, 1:34 PM
  3. Problem installing Sencha Architect 2.1 on Mac os 10.5.8
    By riccardo.terzi in forum Sencha Architect 2.x: Help & Discussions
    Replies: 3
    Last Post: 28 Sep 2012, 10:11 PM
  4. Problem installing SDK tools form PR2
    By gregk in forum Sencha Touch 2.x: Q&A
    Replies: 4
    Last Post: 12 Feb 2012, 9:51 PM
  5. problem installing compass for sass
    By Shranes in forum Sencha Touch 1.x: Discussion
    Replies: 0
    Last Post: 29 Jun 2011, 2:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •