For some reason Ext.device.Geolocation.watchPosition is ignoring frequency value , probably calling in default frequency value.

code
Code:
          Ext.device.Geolocation.watchPosition({
           allowHighAccuracy:true,
           frequency:90000,
           callback: function(position) {
             var location = that.geolocation2json(position)
             Ext.Ajax.request({
                 url: Club.helper.Functions.endpoint('alive'),
                 withCredentials: false,
                 useDefaultXhrHeader: false,
                 params: null,
                 jsonData: {location:location, live:true, status:status},
                 method: 'POST',
                 callback: function(options, success, response) { }
             });
           }
         });
Alternative workaround is to use setInterval