Hello guys,

I have found a syntax error in the source code of the function createEdgePicker() in the Class Ext.field.Date. The function getFullyear() should be --> getFullYear()
ExtJs modern 6.5.1 Original:

createEdgePicker: function() {
var me = this,
minDate = this.getMinDate(),
maxDate = this.getMaxDate();

return Ext.merge({
yearFrom: minDate ? minDate.getFullyear() : (new Date().getFullYear() - 20),
yearTo: maxDate ? maxDate.getFullyear() : (new Date().getFullYear() + 20)
}, me.getEdgePicker());
}

But it has to be

createEdgePicker: function() {
var me = this,
minDate = this.getMinDate(),
maxDate = this.getMaxDate();

return Ext.merge({
yearFrom: minDate ? minDate.getFullYear() : (new Date().getFullYear() - 20),
yearTo: maxDate ? maxDate.getFullYear() : (new Date().getFullYear() + 20)
}, me.getEdgePicker());
}

The reason I have found this error is because the date.Picker ended at year 1997.

I hope you guys can use this fix.

Greetings Paul