Results 1 to 2 of 2

Thread: Button UI pressed colour not taking effect

  1. #1
    Sencha Premium User tlloyduk's Avatar
    Join Date
    Sep 2010
    Posts
    91
    Answers
    1
    Vote Rating
    6
      0  

    Default Button UI pressed colour not taking effect

    Hi Guys

    I'm using Themer 1.3 and struggling to actually customise the aspects of a UI that I want.

    I've made a new "button" UI called "toggle-btn" and I'm applying it as so:

    Code:
    { 
    xtype: 'segmentedbutton', 
    items: [ 
        { 
          ui: 'toggle-btn', 
          allowDepress: false, 
          enableToggle: true, 
          text: 'AND' 
        }, 
        { 
          ui: 'toggle-btn', 
          allowDepress: false, 
          enableToggle: true, 
          pressed: true, 
          text: 'OR' 
        } 
      ] 
    }
    I open my theme in Themer and edit the toggle-btn UI. I set the background colour under "button defaults" to #BDBDBD. I scroll down to "Pressed" and I set the colour I want for when the button is pressed: #1565C0. See screenshot: https://snag.gy/2DQjsB.jpg

    I refresh my theme, build project.... my toggle button correctly uses the background colour set but the pressed colour is still the theme default, as automatically set in: $button-default-background-color-pressed which is #1a2128 as I can see in Themer variables: https://snag.gy/O9ZVRW.jpg

    See screenshot of end result: https://snag.gy/Hsyf3A.jpg

    I would expect the "OR" button to be blue.... surely the UI should be overriding the default ? What am I doing wrong ?

    Cheers for your help

    Tim

  2. #2
    Sencha Premium User tlloyduk's Avatar
    Join Date
    Sep 2010
    Posts
    91
    Answers
    1
    Vote Rating
    6
      0  

    Default

    Interesting.... I accidentally held CTRL whilst pressing the button and it turned the correct shade of blue ?!

Similar Threads

  1. Button pressed torch effect
    By Ethan Long in forum Sencha Touch 2.x: Q&A
    Replies: 1
    Last Post: 10 Sep 2012, 5:14 AM
  2. Button pressed and hover effect on Ext.Image
    By francorobles in forum Ext: Q&A
    Replies: 3
    Last Post: 5 Jan 2012, 5:42 AM
  3. Element.DISPLAY not taking effect
    By super_drone in forum Ext 2.x: Help & Discussion
    Replies: 1
    Last Post: 23 Jan 2008, 11:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •