Results 1 to 10 of 10

Thread: ExtReact Trial

  1. #1
    Sencha Premium User
    Join Date
    Mar 2016
    Posts
    24
    Answers
    1
    Vote Rating
    2
      0  

    Default Answered: ExtReact Trial

    I've signed up for the trial and have received my credentials, however when I attempt to follow the Getting Starting guide and running:

    npm install -g yo @extjs/generator-ext-react
    I get an error:

    fs.js:651
    return binding.open(pathModule._makeLong(path), stringToFlags(flags), mode);
    ^


    Error: EACCES: permission denied, open './package.json'
    at Object.fs.openSync (fs.js:651:18)
    at Object.fs.writeFileSync (fs.js:1300:33)
    at Object.<anonymous> (/usr/local/lib/node_modules/@extjs/generator-ext-react/node_modules/@extjs/ext-react-core/activate.js:8:4)
    at Module._compile (module.js:569:30)
    at Object.Module._extensions..js (module.js:580:10)
    at Module.load (module.js:503:32)
    at tryModuleLoad (module.js:466:12)
    at Function.Module._load (module.js:458:3)
    at Function.Module.runMain (module.js:605:10)
    at startup (bootstrap_node.js:158:16)
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! @extjs/ext-react-core@6.5.1 install: `node activate.js`
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the @extjs/ext-react-core@6.5.1 install script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.


    I'm running it with latest npm on Mac. Any help would be greatly appreciated!


  2. What version of node and npm are you running? We've had some sporadic issues with different variants of v5. Maybe try downgrading to npm 4?

  3. #2
    Sencha User Mark.Brocato's Avatar
    Join Date
    Mar 2015
    Location
    Maryland
    Posts
    481
    Answers
    114
    Vote Rating
    53
      0  

    Default

    What version of node and npm are you running? We've had some sporadic issues with different variants of v5. Maybe try downgrading to npm 4?

  4. #3
    Sencha Premium User
    Join Date
    Mar 2016
    Posts
    24
    Answers
    1
    Vote Rating
    2
      0  

    Default

    I was using 5.4.1. I've downgraded to 4.6.1 and that appears to have worked. Thanks!

    I assume you will be looking to support the latest version of node/npm ASAP?

  5. #4
    Sencha Premium User
    Join Date
    Mar 2016
    Posts
    24
    Answers
    1
    Vote Rating
    2
      0  

    Default

    Quote Originally Posted by Mark.Brocato View Post
    What version of node and npm are you running? We've had some sporadic issues with different variants of v5. Maybe try downgrading to npm 4?
    After seeming to get it working, npm start does not work

    Christophers-MacBook-Pro:eagle-react christopherjakeman$ npm start


    > eagle-react@1.0.0 start /Users/christopherjakeman/Documents/Development/eagle_3/eagle-react
    > webpack-dev-server --progress --colors


    module.js:487
    throw err;
    ^


    Error: Cannot find module 'tapable'
    at Function.Module._resolveFilename (module.js:485:15)
    at Function.Module._load (module.js:437:25)
    at Module.require (module.js:513:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (/usr/local/lib/node_modules/webpack/lib/Compiler.js:8:17)
    at Module._compile (module.js:569:30)
    at Object.Module._extensions..js (module.js:580:10)
    at Module.load (module.js:503:32)
    at tryModuleLoad (module.js:466:12)
    at Function.Module._load (module.js:458:3)
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! eagle-react@1.0.0 start: `webpack-dev-server --progress --colors`
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the eagle-react@1.0.0 start script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.


    npm ERR! A complete log of this run can be found in:
    npm ERR! /Users/christopherjakeman/.npm/_logs/2017-09-08T13_30_14_904Z-debug.log
    Christophers-MacBook-Pro:eagle-react christopherjakeman$
    Seems to me that ExtReact is not anywhere close to being a production ready platform.

  6. #5
    Sencha User Mark.Brocato's Avatar
    Join Date
    Mar 2015
    Location
    Maryland
    Posts
    481
    Answers
    114
    Vote Rating
    53
      0  

    Default

    So I just tried installing ExtReact with npm 5.4.1 on Mac OS and it worked fine.

    Here are the commands I ran:

    Code:
    npm i -g npm@latest # upgrade to npm 5.4.1
    npm i -g yo @extjs/generator-ext-react
    yo @extjs/ext-react # then follow the steps presented by yeoman, picked option to add example code
    cd (project-name)
    npm start
    The app compiled and opened in the browser as expected.

  7. #6
    Sencha Premium User
    Join Date
    Mar 2016
    Posts
    24
    Answers
    1
    Vote Rating
    2
      0  

    Default

    Quote Originally Posted by Mark.Brocato View Post
    So I just tried installing ExtReact with npm 5.4.1 on Mac OS and it worked fine.

    Here are the commands I ran:

    Code:
    npm i -g npm@latest # upgrade to npm 5.4.1
    npm i -g yo @extjs/generator-ext-react
    yo @extjs/ext-react # then follow the steps presented by yeoman, picked option to add example code
    cd (project-name)
    npm start
    The app compiled and opened in the browser as expected.
    Tried running as both root and non-root user, and still get the same issues:

    Christophers-MacBook-Proevelopment christopherjakeman$ sudo su
    Password:
    sh-3.2# npm i -g yo @extjs/generator-ext-react
    /usr/local/bin/yo -> /usr/local/lib/node_modules/yo/lib/cli.js
    /usr/local/bin/yo-complete -> /usr/local/lib/node_modules/yo/lib/completion/index.js


    > @extjs/ext-react-core@6.5.1 install /usr/local/lib/node_modules/@extjs/generator-ext-react/node_modules/@extjs/ext-react-core
    > node activate.js


    fs.js:651
    return binding.open(pathModule._makeLong(path), stringToFlags(flags), mode);
    ^


    Error: EACCES: permission denied, open './package.json'
    at Object.fs.openSync (fs.js:651:18)
    at Object.fs.writeFileSync (fs.js:1300:33)
    at Object.<anonymous> (/usr/local/lib/node_modules/@extjs/generator-ext-react/node_modules/@extjs/ext-react-core/activate.js:8:4)
    at Module._compile (module.js:569:30)
    at Object.Module._extensions..js (module.js:580:10)
    at Module.load (module.js:503:32)
    at tryModuleLoad (module.js:466:12)
    at Function.Module._load (module.js:458:3)
    at Function.Module.runMain (module.js:605:10)
    at startup (bootstrap_node.js:158:16)
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! @extjs/ext-react-core@6.5.1 install: `node activate.js`
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the @extjs/ext-react-core@6.5.1 install script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.


    npm ERR! A complete log of this run can be found in:
    npmERR! /var/root/.npm/_logs/2017-09-08T14_58_00_843Z-debug.log

  8. #7
    Sencha User Mark.Brocato's Avatar
    Join Date
    Mar 2015
    Location
    Maryland
    Posts
    481
    Answers
    114
    Vote Rating
    53
      0  

    Default

    Maybe an issue with how you have node installed? I use nvm.

  9. #8
    Sencha Premium User
    Join Date
    Mar 2016
    Posts
    24
    Answers
    1
    Vote Rating
    2
      0  

    Default

    Quote Originally Posted by Mark.Brocato View Post
    Maybe an issue with how you have node installed? I use nvm.
    I use homebrew. I've completely removed nodejs and reinstalled and still get the same issue.

  10. #9
    Sencha User Mark.Brocato's Avatar
    Join Date
    Mar 2015
    Location
    Maryland
    Posts
    481
    Answers
    114
    Vote Rating
    53
      0  

    Default

    In that case I definitely recommend nvm. It makes it a lot easier to swap between node versions, try something, and go back if things don't go as planned.

    https://github.com/creationix/nvm

  11. #10
    Sencha User
    Join Date
    Nov 2010
    Posts
    1
    Vote Rating
    0
      0  

    Default

    Same issue here.

    @extjs/ext-react-core@6.5.1 install: `node activate.js`
    npm ERR! Exit status 1

    Using the ejected created-react-app

    Kai

Similar Threads

  1. Sencha ExtReact 6.5.1 is Now Available
    By mitchellsimoens in forum Q&A
    Replies: 0
    Last Post: 27 Jul 2017, 5:23 AM
  2. ExtReact does not fit Redux best practices
    By tempvalue in forum Q&A
    Replies: 8
    Last Post: 29 Jun 2017, 11:04 AM
  3. ExtReact box-sizing CSS
    By geniny in forum Q&A
    Replies: 6
    Last Post: 27 Jun 2017, 10:34 AM
  4. Using extReact with Extjs
    By philiparad in forum Q&A
    Replies: 1
    Last Post: 25 May 2017, 11:45 AM
  5. Sencha ExtReact is Now Available
    By mitchellsimoens in forum Q&A
    Replies: 0
    Last Post: 16 May 2017, 4:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •