Results 1 to 6 of 6

Thread: Running automated test on IE11 using standalone Selenium server

  1. #1
    Sencha User
    Join Date
    Aug 2017
    Posts
    5
    Vote Rating
    0
      0  

    Default Answered: Running automated test on IE11 using standalone Selenium server

    I created some tests that run fine on my Chrome local browser. I now want to run these tests on a local IE11 browser.

    I downloaded the latest Selenium Standalone Server (3.5.3) and the IEDriverServer.exe which are both in my PATH. Per Selenium docs, I updated my registry for running the driver with IE11.

    I am running the selenium server with:
    Code:
     java -jar selenium-server-standalone-3.5.3.jar
    It seems to start OK:

    Code:
    C:\Users\fhardin\bin>java -jar selenium-server-standalone-3.5.3.jar
    16:16:19.697 INFO - Selenium build info: version: '3.5.3', revision: 'a88d25fe6b'
    16:16:19.698 INFO - Launching a standalone Selenium Server
    2017-09-16 16:16:19.720:INFO::main: Logging initialized @214ms to org.seleniumhq.jetty9.util.log.StdErrLog
    16:16:19.770 INFO - Driver class not found: com.opera.core.systems.OperaDriver
    16:16:19.796 INFO - Driver provider class org.openqa.selenium.safari.SafariDriver registration is skipped: registration capabilities Capabilities [{browserName=safari, version=, platform=MAC}] does not match the current platform VISTA
    16:16:19.820 INFO - Using the passthrough mode handler
    2017-09-16 16:16:19.846:INFO:osjs.Server:main: jetty-9.4.5.v20170502
    2017-09-16 16:16:19.863:WARN:osjs.SecurityHandler:main: ServletContext@o.s.j.s.ServletContextHandler@520a3426{/,null,STARTING} has uncovered http methods for path: /
    2017-09-16 16:16:19.866:INFO:osjsh.ContextHandler:main: Started o.s.j.s.ServletContextHandler@520a3426{/,null,AVAILABLE}
    2017-09-16 16:16:20.094:INFO:osjs.AbstractConnector:main: Started ServerConnector@23faf8f2{HTTP/1.1,[http/1.1]}{0.0.0.0:4444}
    2017-09-16 16:16:20.095:INFO:osjs.Server:main: Started @590ms
    16:16:20.095 INFO - Selenium Server is up and running
    I configured Sencha Test to run with a GenericWebserver per Sencha Docs. When I run the test for IE11, I get this error from Sencha Studio:

    Code:
    Error: Invalid timeout type specified:
     ms Build info: version: '3.5.3', revision: 'a88d25fe6b',time: '2017-08-29T12:54:15.039Z' System info: host: 'PA10030928', ip: '172.16.241.3', os.name: 'Windows 7', os.arch: 'amd64', os.version: '6.1', java.version: '1.8.0_144'
     Driver info: driver.version: unknown at url("http://localhost/htdocs/figleaftraining/extjs5/walk/walk3-8/")
     - C:\Users\fhardin\Sencha\Test\2_1_1_31\resources\app.asar\node_modules\orion-core\serve\context\WebDriver.js:124:18 at timeouts("script", 10000)
     - C:\Users\fhardin\Sencha\Test\2_1_1_31\resources\app.asar\node_modules\orion-core\serve\context\WebDriver.js:123:18 at init()
     - C:\Users\fhardin\Sencha\Test\2_1_1_31\resources\app.asar\node_modules\orion-core\serve\context\WebDriver.js:118:18
    Any ideas why this does not work? Is there any additional setup needed?

    Thanks,
    Fred

  2. It appears the newer versions of Selenium Server and IEDriverServer may cause some issues together, with others online also encountering the same error.

    Numerous sites online talk about downgrading both the Selenium Server and IEDriverServer. I tried using version 3.4 of Selenium Server and IEDriverServer, and this combination works fine with Sencha Test.

    You can download the older versions of both from here: http://selenium-release.storage.goog...html?path=3.4/

  3. #2
    Sencha User joel.watson's Avatar
    Join Date
    Nov 2014
    Posts
    3,120
    Answers
    443
    Vote Rating
    184
      0  

    Default

    Hi Fred--

    Which version of the IEDriver are you using?

    Thanks
    Joel

  4. #3
    Sencha User
    Join Date
    Aug 2017
    Posts
    5
    Vote Rating
    0
      0  

    Default

    Joel,

    It is the latest version from Selenium: 3.5.1.0.



    Fred

  5. #4
    Sencha - Sales Team daniel.gallo's Avatar
    Join Date
    Apr 2009
    Location
    Redwood City, CA
    Posts
    94
    Answers
    5
    Vote Rating
    16
      0  

    Default

    It appears the newer versions of Selenium Server and IEDriverServer may cause some issues together, with others online also encountering the same error.

    Numerous sites online talk about downgrading both the Selenium Server and IEDriverServer. I tried using version 3.4 of Selenium Server and IEDriverServer, and this combination works fine with Sencha Test.

    You can download the older versions of both from here: http://selenium-release.storage.goog...html?path=3.4/
    Daniel Gallo
    Senior Solutions Architect
    Sencha Inc.

  6. #5
    Sencha User
    Join Date
    Aug 2017
    Posts
    5
    Vote Rating
    0
      0  

    Default

    Daniel,

    I tried the older 3.4 versions of Selenium Standalone Server and IEDriverServer, and I was able to get things to work.

    Thanks!
    Fred

  7. #6
    Sencha User
    Join Date
    Oct 2017
    Posts
    1
    Vote Rating
    1
      1  

    Default

    I had the same problem. Nice to find this forum. Thanks!

Similar Threads

  1. Replies: 3
    Last Post: 10 Aug 2017, 11:24 AM
  2. how to use selenium automated test with Extjs
    By Ganesh020981 in forum Ext 6: Q&A
    Replies: 1
    Last Post: 6 Dec 2016, 4:25 PM
  3. Replies: 3
    Last Post: 3 Aug 2016, 5:01 AM
  4. Replies: 2
    Last Post: 2 Aug 2016, 7:31 PM
  5. Replies: 12
    Last Post: 14 Jun 2016, 8:32 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •