Results 1 to 3 of 3

Thread: ExtJs Premium - Exporter plugin error

    Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Ext JS Premium Member
    Join Date
    Sep 2008
    Posts
    157

    Default ExtJs Premium - Exporter plugin error

    Hi all,
    i try to add Ext.grid.plugin.Exporter in my project in SA.
    I'm Premium User, i downloaded the package and then uploaded the files into the packages folder inside ext/ of my project.
    On build web app from SA or from CMD,
    there is an error:

    [INF] Processing Build Descriptor : default (development environment)
    [ERR] Cannot satisfy requirements for "exporter"!
    [ERR] The following versions cannot be satisfied:
    [ERR] ZG: exporter (No matches!)

    Any idea how solve this?
    In SA i can't remove "exporter" from resources->library...

    Thanks,
    Luca F.


    Version: 4.2.2.282
    Channel: 4.2-stable
    Platform: 1.6.2.49 - darwin x64
    Renderer: 56.0.2924.87
    Cmd: 6.5.1.240
    Framework: Ext JS 6.2.x Classic

  2. #2
    Sencha - Sustaining Engineer tristan.lee's Avatar
    Join Date
    Mar 2015
    Location
    Central Ohio
    Posts
    1,579

    Default

    Did you make sure to get the Premium Addon package for 6.2.1 and not 6.5.x? I just attempted this myself and it compiled without error. I downloaded ext-addons-6.2.1.zip and moved the exporter directory to {MyApp}/ext/packages/exporter and started app watch to verify it met the requirements. It builds successfully. Remove that directory and I get the same error as you.
    Tristan Lee
    Sencha Inc - Sustaining Engineer


    Having an issue? Help us help you - be detailed; provide some code; demonstrate with a fiddle (fiddle.sencha.com)

    Embed your fiddle in your post: [FIDDLE]id[/FIDDLE]

  3. #3

    Default

    Thanks tristan.lee,

    Your suggested solution worked for me also.

    I copied exporter folder from downloaded libraries from sencha (from "ext-addons-6.6.0/packages/exporter") to my workspace directory (webapp/ext/packages)

    Which solved the problem now i can build my exporter application without error.

    Thank You very much...!!!

Similar Threads

  1. Ext.grid.plugin.Exporter
    By pkbhavani in forum Ext JS 6.x Bugs
    Replies: 1
    Last Post: 26 Jun 2017, 6:08 AM
  2. Ext.plugin.grid.exporter
    By jamArk in forum Ext JS 6.x Q&A
    Replies: 1
    Last Post: 22 Jan 2016, 10:14 PM
  3. Replies: 2
    Last Post: 1 Jul 2015, 12:15 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •