Results 1 to 5 of 5

Thread: Charts in Architect 4.2.2 with Extjs 6.5.2

  1. #1
    Sencha Premium User
    Join Date
    Mar 2011
    Location
    Farmers Branch, TX
    Posts
    58
    Answers
    1
    Vote Rating
    2
      0  

    Default Charts in Architect 4.2.2 with Extjs 6.5.2

    I recently upgraded from Extjs 6.2 to 6.5.2 and all my charts are now broken. Previously I was requiring 'sencha-charts' in my Library. Everything worked when targeting Extjs 6.2. I found a thread that said I should require just 'charts' for 6.5 but that didn't work. I had to specifically include "ext/packages/charts/classic/charts-debug.js" in my index.html file to get it to even load. What is the correct way to include charts in your Architect 4.2.2 project targeting Ext-js 6.5.2 ?

    I'm on Windows 7.

    Thanks,
    John

    Also I should note that I am not using Sencha Cmd tools, just Publishing to my webapp folder.

  2. #2
    Sencha User
    Join Date
    Sep 2014
    Location
    Central Europe
    Posts
    795
    Answers
    103
    Vote Rating
    52
      0  

    Default

    So you are not using Sencha Cmd at all right? Because with that everything is automatic. Well charts are separate package, I actually never developed apps without Sencha Cmd but I would assume that you have to include it separately into the index.html because it's not part of ext-all file if I am not mistaken.

  3. #3
    Sencha - Support Team bjdurham85's Avatar
    Join Date
    Mar 2014
    Posts
    928
    Answers
    53
    Vote Rating
    18
      0  

    Default

    Hi--,

    Just wanted to see if you were still having trouble. I just generated a new project, added a chart and it automatically added the "sencha-charts' to my 6.5 project. If so, is it throwing any errors in the Log/Cmd tabs?

    Bryan

  4. #4
    Sencha Premium User
    Join Date
    Mar 2011
    Location
    Farmers Branch, TX
    Posts
    58
    Answers
    1
    Vote Rating
    2
      0  

    Default

    Well, I finally got some time to get back to this project. I'm still having problems with charts in 6.5.2 using Architect 4.2.2 on Windows 7.

    I deleted my view with the charts and started with a new window. Just dropped in a 3D column chart, added a store for the series and after I publish to my local app server (Tomcat 9) when I bring up the app, I see the following errors in the browser debugger:

    Loading failed for the <script> with source “http://localhost:8080/ClientPortal/E...13029315452”.
    [E] [Ext.Loader] Some requested files failed to load. ext-all-debug.js:10025:21
    Loading failed for the <script> with source “http://localhost:8080/ClientPortal/E...13029315452”.
    Loading failed for the <script> with source “http://localhost:8080/ClientPortal/E...13029315452”.
    Loading failed for the <script> with source “http://localhost:8080/ClientPortal/E...13029315452”.

    I'm not using Sencha Cmd from within Architect but publishing the app directly to my Eclipse project directory. The reason I switched away from Sencha Cmd is because I found it difficult to debug in. It's much easier with individual files.

    I noticed that in the Library Resources property panel, it's showing:
    Library Requires: sencha-charts.

    I tried to delete this, thinking that it was needed by the older version but it won't let me delete it.

    I should note that this Architect project file has been upgraded several times and I think it started out life as an Architect 2 project with ext-3.2.

    The ext code is in a separate war file and I point to it in the Library Base Path ../ext-6.5.2/ext/

    This setup has worked for me for quite some time and it only started breaking when I upgraded to ext-6.5.2 and switched from using Sencha Cmd to just publishing from within Architect.

    Is there some chart package that needs to be specifically included somewhere? From the console log, it seems to be looking for these files in the wrong place.

    Any suggestions would be appreciated.

    John

  5. #5
    Sencha Premium User
    Join Date
    Oct 2012
    Location
    United States
    Posts
    100
    Answers
    10
    Vote Rating
    11
      0  

    Default

    Quote Originally Posted by jbender11 View Post
    Well, I finally got some time to get back to this project. I'm still having problems with charts in 6.5.2 using Architect 4.2.2 on Windows 7.

    I deleted my view with the charts and started with a new window. Just dropped in a 3D column chart, added a store for the series and after I publish to my local app server (Tomcat 9) when I bring up the app, I see the following errors in the browser debugger:

    Loading failed for the <script> with source “http://localhost:8080/ClientPortal/E...13029315452”.
    [E] [Ext.Loader] Some requested files failed to load. ext-all-debug.js:10025:21
    Loading failed for the <script> with source “http://localhost:8080/ClientPortal/E...13029315452”.
    Loading failed for the <script> with source “http://localhost:8080/ClientPortal/E...13029315452”.
    Loading failed for the <script> with source “http://localhost:8080/ClientPortal/E...13029315452”.

    I'm not using Sencha Cmd from within Architect but publishing the app directly to my Eclipse project directory. The reason I switched away from Sencha Cmd is because I found it difficult to debug in. It's much easier with individual files.

    I noticed that in the Library Resources property panel, it's showing:
    Library Requires: sencha-charts.

    I tried to delete this, thinking that it was needed by the older version but it won't let me delete it.

    I should note that this Architect project file has been upgraded several times and I think it started out life as an Architect 2 project with ext-3.2.

    The ext code is in a separate war file and I point to it in the Library Base Path ../ext-6.5.2/ext/

    This setup has worked for me for quite some time and it only started breaking when I upgraded to ext-6.5.2 and switched from using Sencha Cmd to just publishing from within Architect.

    Is there some chart package that needs to be specifically included somewhere? From the console log, it seems to be looking for these files in the wrong place.

    Any suggestions would be appreciated.

    John

    The requires should be in your app.json, it could also be looking in the wrong place if the improper version is defined. but you could also in your library resource in architect add that to the library require section.

Similar Threads

  1. Architect 3 problems with pie charts
    By Tingo in forum Sencha Architect 3.x: Q&A
    Replies: 1
    Last Post: 2 Apr 2015, 7:38 PM
  2. Architect problems with charts
    By Tingo in forum Sencha Architect 3.x: Bugs
    Replies: 0
    Last Post: 1 Apr 2015, 2:32 PM
  3. need help doing touch charts with Architect
    By jwbworks in forum Sencha Architect 2.x: Help & Discussions
    Replies: 3
    Last Post: 13 Aug 2012, 9:42 AM
  4. Several issues with Charts in architect 2
    By stevesether in forum Sencha Architect 2.x: Help & Discussions
    Replies: 4
    Last Post: 29 Apr 2012, 10:18 AM
  5. ExtJS4 Charts - Use ExtJS 3.2.1 Stores in ExtJS 4 Charts
    By beerumrakesh in forum Ext: Discussion
    Replies: 0
    Last Post: 12 Jun 2011, 11:19 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •