Results 1 to 5 of 5

Thread: Error: Cannot satisfy requirements for "modern"

    Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Sencha User
    Join Date
    Oct 2017
    Posts
    4
    Vote Rating
    2
      0  

    Default Error: Cannot satisfy requirements for "modern"

    Getting "Cannot satisfy requirements for "modern" error after running `npm start`.

    Repro(s)

    rm -rf node_modules/@extjs
    npm install
    npm start


    Code:
    ERROR in [@extjs/reactor-webpack-plugin]: Error: Cannot satisfy requirements for "modern"!
    The following versions cannot be satisfied:
    null: modern (No matches!)
    
    
    BUILD FAILED
    com.sencha.exceptions.BasicException: com.sencha.exceptions.ExVersion: Cannot resolve package requirements

  2. #2
    Sencha User
    Join Date
    Oct 2017
    Posts
    4
    Vote Rating
    2
      0  

    Default

    This issue could be related to the NPM registry errors happening earlier this week. Upgrading ExtReact to 6.5.2 seems to fix it.
    In package.json, change "@extjs/ext-react": "^6.5.1" to "@extjs/ext-react": "^6.5.2" then run `npm update`

  3. #3
    Sencha - Sustaining Engineer tristan.lee's Avatar
    Join Date
    Mar 2015
    Location
    Central Ohio
    Posts
    1,495
    Vote Rating
    77
      0  

    Default

    That's a strange "fix" because ^6.5.1 should have installed @extjs/ext-reactor 6.5.2. At least it does for me.
    npm view @extjs/ext-react version >> 6.5.2
    Tristan Lee
    Sencha Inc - Sustaining Engineer


    Having an issue? Help us help you - be detailed; provide some code; demonstrate with a fiddle (fiddle.sencha.com)

    Embed your fiddle in your post: [FIDDLE]id[/FIDDLE]

  4. #4

    Join Date
    Oct 2017
    Posts
    8
    Vote Rating
    0
      0  

    Default

    tristan.lee I face the same issue too.

  5. #5
    Sencha - Sustaining Engineer tristan.lee's Avatar
    Join Date
    Mar 2015
    Location
    Central Ohio
    Posts
    1,495
    Vote Rating
    77
      0  

    Default

    After removing node_modules and doing an npm install, does it not resolve the issue? I've not been able to replicate this.
    Tristan Lee
    Sencha Inc - Sustaining Engineer


    Having an issue? Help us help you - be detailed; provide some code; demonstrate with a fiddle (fiddle.sencha.com)

    Embed your fiddle in your post: [FIDDLE]id[/FIDDLE]

Similar Threads

  1. Modern android class requirements
    By bogdica21 in forum Ext 6: Q&A
    Replies: 1
    Last Post: 26 May 2016, 5:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •