Results 1 to 2 of 2

Thread: Sencha CMD package build dependencies problem

  1. #1
    Sencha Premium User jvandemerwe's Avatar
    Join Date
    Apr 2009
    Raalte, Netherlands
    Vote Rating

    Default Sencha CMD package build dependencies problem

    I have tried now for half a day, but I don't get "Sencha package build" working.

    Why is it that "Sencha package build" keep complaining that it can't find my Ext JS classes (f.e. Ext.panel.Panel)? I have done this so often, but with the latest Sencha Cmd it simply doesn't work.
    Has this been tested by Sencha, I mean with more than just the Readme file in the Src folder?

    At the top of my package.json:

     "name": "ext-markdown-panel",
      "sencha": {
        "namespace": "MdPanel",
        "type": "code",
        "toolkit": "",
        "framework": "ext",
        "creator": "Intranet",
        "summary": "Panel that supports Remarkable.js Markdown (view only)",
        "detailedDescription": "Panel that supports Remarkable.js Markdown (view only)",
        "version": "1.0.0",
        "compatVersion": "1.0.0",
        "format": "1",
    when I put "classic" in the "toolkit" it is not even processing anything.

    [INF] Processing Build Descriptor : default
    [ERR] Cannot satisfy requirements for "classic"!
    [ERR]    The following versions cannot be satisfied:
    [ERR]       ext-markdown-panel: classic (No matches!)
    [ERR] Cannot resolve package requirements

    As I can see the .sencha folder has disappeared, so that leaves also a few options.

    The question is quite simple, "why is within a workspace (following the documentation) a local package not simply taking the "ext" folder within that workspace, when I do a "sencha package build"?

    ** And a recommendation to Sencha Inc.: please make that the documention of Sencha Cmd is up to date, which isn't !!!
    Professional Sencha development since 2007.

  2. #2
    Ext JS Premium Member neongrau's Avatar
    Join Date
    Mar 2007
    Vote Rating


    I'm currently struggling with packages too. I had them working with a 6.0.x app and tried to migrate a package into 6.5 but it's also failing because it can't resolve it's dependencies to all the basic Ext components.

    And also at the same time even when i generate a new package and put a simple testing component inside and require this package in an app the app will not include that package from the workspace.

    I'm suspecting the 6.5.x builds are horribly broken.

    This is a huge mess at the moment.

Similar Threads

  1. Replies: 9
    Last Post: 5 Apr 2016, 3:00 PM
  2. sencha package build fails because Ext dependencies
    By mysticav in forum Sencha Cmd
    Replies: 3
    Last Post: 19 May 2015, 10:44 AM
  3. Sencha SDK problem: app build dumps app dependencies, then fails
    By 7C Dev in forum Sencha Touch 2.x: Q&A
    Replies: 2
    Last Post: 13 Oct 2012, 7:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts