Results 1 to 4 of 4

Thread: No test scenario found

  1. #1

    Join Date
    Dec 2014
    Posts
    2
    Vote Rating
    0
      0  

    Default No test scenario found

    I created a very simple test and wanted to get it to be run by our CI-server.
    The test works fine from Sencha Test and from the windows command line. As soon as I try to start it on our ubuntu-server (inside a docker-container) I get the following error:

    Code:
    root@4271fbe220bb:~/air-test# stc run -s test/login -p chromeheadless
    Sencha Test v2.2.0.96
    [ERROR] [RunCommand] No test scenario found on /root/air-test/test/login
    Same thing happens if I follow the suggestion from the other thread (https://www.sencha.com/forum/showthr...ha-Test-by-CLI)

    Code:
    root@4271fbe220bb:~/air-test/test/login# stc run -p chromeheadless
    Sencha Test v2.2.0.96
    [ERROR] [RunCommand] No test scenario found on /root/air-test/test/login
    Both commands work just fine from my windows commandline in their respective folders.

    I checked permissions on the ubuntu machine, that isn't the problem. Tried using both sencha test 2.1 and 2.2 EA.

    I attached the test-files here air-test.zip

    Thanks in advance

  2. #2
    Sencha - Sales Team daniel.gallo's Avatar
    Join Date
    Apr 2009
    Location
    Redwood City, CA
    Posts
    143
    Answers
    12
    Vote Rating
    20
      0  

    Default

    In your workspace.json, please try replacing the two backslashes in the path with one forward slash.

    E.g. Change this:

    Code:
    "path": "test\\project.json"
    To this:

    Code:
    "path": "test/project.json"
    Then try running the tests again.
    Daniel Gallo
    Senior Solutions Architect
    Sencha Inc.

  3. #3

    Join Date
    Dec 2014
    Posts
    2
    Vote Rating
    0
      0  

    Default

    Hey Daniel,

    thank you very much. That solved the problem.


    Unfortunately another problem has taken it's place. When I try to run sencha test now I get:

    Code:
    stc run -p chromeheadless -s test/login/
    Sencha Test v2.2.0.96
    [INFO] Proxy Server open on port 8000
    [AGENT: 1] Launching agent
    [ERROR] mesg: ttyname failed: Inappropriate ioctl for device
    [ERROR] mesg: ttyname failed:
    [ERROR] Inappropriate ioctl for device
    My colleague's theory is that it has to do with the "progress bar" inside of the docker containeer, but we aren't really sure about that. Maybe you have an idea?

    Thanks in advance.

  4. #4
    Sencha - Sales Team daniel.gallo's Avatar
    Join Date
    Apr 2009
    Location
    Redwood City, CA
    Posts
    143
    Answers
    12
    Vote Rating
    20
      0  

    Default

    Unfortunately I've not seen that error before, but it does seem like an environment issue. I'll see if anyone on the team here has ideas.
    Daniel Gallo
    Senior Solutions Architect
    Sencha Inc.

Similar Threads

  1. Replies: 3
    Last Post: 3 Aug 2016, 5:01 AM
  2. Replies: 2
    Last Post: 2 Aug 2016, 7:31 PM
  3. Replies: 4
    Last Post: 26 Jan 2016, 3:13 AM
  4. Replies: 2
    Last Post: 20 Jun 2012, 9:31 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •