According to he document:

With Ext JS 6.5.1, the class requirements of dynamic packages can be passed to the application build and allow it to include only those classes needed, as shown below:
Code:
"output": {
    "js": {
        "filter": "minimum" 
    }
}
There is a class which extends `Ext.form.Panel` in one of dynamic packages of my application, and I am using `"filter": "minimum"`.

But when I build the application (`sencha app build -uses`), `Ext.form.Panel` is neither included in the app.js, nor the package's output.
And it throws an error `c is not a constructor` in the console when I visit it in a browser.

Actully, it happens not only for extended classes, but also required classes, it seems `"filter": "minimum"` doesn't work at all