Results 1 to 3 of 3

Thread: Extjs 6.2 and Extjs 6.5 modern app with grid plugins fails to load on android

    Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Sencha User
    Join Date
    Dec 2011
    Posts
    6

    Default Extjs 6.2 and Extjs 6.5 modern app with grid plugins fails to load on android

    When compiling my app with cordova while plugins option is enabled, the apk hangs on splash screen on android (both android 5.0 and 6.1). When plugins code is removed, the app loads just fine. I have run the same code both on ExtJs 6.2 modern and Extjs 6.5 both with same results.
    Following is a snippet of my code: (This loads fine)
    Code:
    xtype: 'grid', columns: [{ text: 'Item', dataIndex: 'item', flex: 4 },
            { text: 'Qty', dataIndex: 'qty', flex: 2},
            { text: 'Price', dataIndex: 'price',align:'center', flex: 1.8}, 
            { text: 'Total', flex: 2, align: 'right'}],
            data: [
                { item: 'Mosi', qty: "3", disc: "0.75", price: "7" },
                { item: 'Castle', qty: "13", disc: "0.50", price: "8" },
                { item: 'Castle Light', qty: "6", disc: "0", price: "13" },
                { item: 'Hansa', qty: "30", disc: "0", price: "5" }
            ]
        }
    (This hangs on splash screen)
    Code:
    xtype: 'grid', columns: [{ text: 'Item', dataIndex: 'item', flex: 4 },
            { text: 'Qty', dataIndex: 'qty', flex: 2,summary: 'count'},
            { text: 'Price', dataIndex: 'price',align:'center', flex: 1.8}, 
            { text: 'Total', flex: 2, align: 'right'}],
            plugins:{gridsummaryrow:true},
            data: [
                { item: 'Mosi', qty: "3", disc: "0.75", price: "7" },
                { item: 'Castle', qty: "13", disc: "0.50", price: "8" },
                { item: 'Castle Light', qty: "6", disc: "0", price: "13" },
                { item: 'Hansa', qty: "30", disc: "0", price: "5" }
            ]
        }

  2. #2

    Default

    Have you required the plugin class?

  3. #3
    Sencha User
    Join Date
    Dec 2011
    Posts
    6

    Default

    Hi, I have required the plugin classes as follows:
    HTML Code:
    requires: [
           'Ext.grid.plugin.Editable','Ext.grid.plugin.SummaryRow'
        ],
    But still failed to onload on android

Similar Threads

  1. Replies: 1
    Last Post: 8 Mar 2017, 6:01 PM
  2. Replies: 8
    Last Post: 7 Oct 2016, 7:30 AM
  3. Replies: 3
    Last Post: 14 Mar 2016, 10:36 AM
  4. Replies: 1
    Last Post: 9 Mar 2016, 9:05 AM
  5. Replies: 1
    Last Post: 21 Nov 2015, 3:35 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •