On macOS 10.12.6 after installing cmd-6.5.3-osx.zip I get this error:

Code:
$ sencha
Sencha Cmd v6.5.3.6
java.lang.UnsupportedClassVersionError: com/sencha/core/functional/Func : Unsupported major.minor version 51.0
I have

Code:
$ java -version
java version "1.8.0_121"
Java(TM) SE Runtime Environment (build 1.8.0_121-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.121-b13, mixed mode)
This does not happen if I download and install the nightly cmd-6.5.3.6-osx-20180207.zip including the JRE.

Does anyone have any idea what might be causing this?

Thanks,
Horst