Results 1 to 7 of 7

Thread: x-keyboard-mode is showing everywhere after 6.6.0 update.

  1. #1
    Sencha Premium User
    Join Date
    Jan 2018
    Posts
    6

    Default x-keyboard-mode is showing everywhere after 6.6.0 update.

    After 6.6.0 update, there are some problems.

    All component has a dotted outline when It has focus.

    I checked what it is.

    It turns out x-keyboard-mode.

    I tried to turn off 'enableKeyboardMode' config. But it's not working.


    And does Ext.decode and .down methods change inner logic??

    Ext.decode can't parse if there is comma end of the structure anymore.

    ex)
    {
    "data" : "test",
    "data2": "test",
    }

    I know it's wrong grammar for JSON, but Ext.decode works before. (Ext 6.5.2)


    and down method fails to get component.

    I tried to get component with 'xtype' selector, 90% of apps are okay. 10% fails to get component with errors.

    Error: candidate.isXType function is not a function.

    It was working with Ext 6.5.2 version.

    Thanks.

  2. #2
    Sencha Premium User
    Join Date
    Jun 2017
    Location
    China
    Posts
    35
    Answers
    1

    Default

    I have the same issue...... get component with 'xtype' selector, it will be an error.But I don't know why....

  3. #3
    Sencha Premium Member richardvd's Avatar
    Join Date
    Jun 2011
    Location
    NL
    Posts
    255
    Answers
    22

    Default

    Regarding x-keyboard-mode, that's a feature. Use this to get the pre Ext JS 6.6.0 behaviour back:
    Code:
    Ext.setEnableKeyboardMode(true);
    Release Notes for Ext JS 6.6.0

    New Features


    • Misc (5)
      • EXT-646 Focus styling should be enabled by default on desktop devices in Classic toolkit

  4. #4
    Sencha Premium User
    Join Date
    Jul 2017
    Posts
    15
    Answers
    1

    Default

    Quote Originally Posted by richardvd View Post
    Regarding x-keyboard-mode, that's a feature. Use this to get the pre Ext JS 6.6.0 behaviour back:
    Code:
    Ext.setEnableKeyboardMode(true);
    Hi Richard,

    It seems that it not works as supposed to, according to the documentation. See my fiddle here. Click on splitter collapse button and you will see a border inside splitter. Pseudo ::after element with class ".x-keyboard-mode .x-splitter-focus:after" is added even if I use classic toolkit and Ext.enableKeyboardMode is set to false by default.

    Is there any way to disable it? It is quite annoying and currently I'm 'workarounding' it in unwanted places by overwriting css styles which cause additional unnecessary effort.

    Best regards,
    Maciej

  5. #5
    Sencha Premium Member richardvd's Avatar
    Join Date
    Jun 2011
    Location
    NL
    Posts
    255
    Answers
    22

    Default

    Again, just pass true to get the pre Ext JS 6.6.0 behaviour back.

    I agree there is a documentation error. The red part below is what is wrong, and I added the correction in green.

    When set to true, focus styling will be applied to focused elements based on the user interaction mode: when keyboard was used to focus an element, focus styling will be visible but not when element was focused otherwise (e.g. with mouse, touch, or programmatically). The keyboardMode property will then reflect the last user interaction mode, which is pre-Ext JS 6.6 behavior. Setting this option to false disables keyboard mode tracking and results in focus styling always being applied to focused elements, which is pre-Ext JS 6.5 behavior.

  6. #6
    Sencha Premium User
    Join Date
    Jul 2017
    Posts
    15
    Answers
    1

    Default

    Thanks,


    Indeed, it works. Probably it was mine misunderstanding of documentation, because I thought that setting it to false will turn off new feature. Now I see I was wrong. Thanks once again!


    Regards,
    Maciej

  7. #7
    Sencha User
    Join Date
    Mar 2011
    Location
    Arvada, CO
    Posts
    404
    Answers
    11

    Default

    FYI, I reported this to Sencha Support, and their response was that before 6.5, enableKeyboardMode false was the intended functionality. This seemed odd that they removed the functionality in 6.5, but then had it return in 6.6, without a clear way of configuring it. Yes, you can call the setter method, but the initial logic to set it is based on Ext.isModern || !Ext.os.is.Desktop, so it doesn't make sense to override that. It also seems strange that we have to call this method to override styling, so I had them open a feature request (EXTJS-28239) to make this configurable through the theme or app.json file. Unsure if that is a better approach, but from a style standpoint, it makes sense.

Similar Threads

  1. keyboard not showing up on htc inspire having android 2.3.3
    By MPMorankar in forum Sencha Touch 2.x: Q&A
    Replies: 0
    Last Post: 25 Nov 2014, 10:28 PM
  2. [FIXED] Tree Panel Keyboard Navigation Flipped In RTL Mode
    By ibnesayeed in forum Ext:Bugs
    Replies: 1
    Last Post: 16 Apr 2013, 5:44 AM
  3. IOS 6 - Screen lock showing keyboard
    By arislaw in forum Sencha Touch 1.x: Q&A
    Replies: 3
    Last Post: 29 Oct 2012, 4:46 AM
  4. Prevent keyboard from showing?
    By justinKohactive in forum Sencha Touch 2.x: Q&A
    Replies: 1
    Last Post: 13 Jan 2012, 9:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •