Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Open tool ext-gen is not installing

    You found a bug! We've classified it as a bug in our system. We encourage you to continue the discussion and to find an acceptable workaround while we work on a permanent fix.
  1. #11
    Sencha User
    Join Date
    Mar 2012
    Location
    Pennsylvania
    Posts
    37
    Vote Rating
    0
      0  

    Default

    To shed some more light on this. I was able to get it to work following the same steps on my laptop (but doesn't work on my desktop). So this appears to be an environment issue and/or the server is denying something that is sent in the payload based on that environment.

  2. #12
    Sencha Premium User
    Join Date
    Jun 2016
    Posts
    149
    Vote Rating
    40
      0  

    Default

    Any update on this? My password doesn't contain any special characters, but I still get the same error as others reported here.

  3. #13

    Default

    I had the same issue and I tried all the solutions of this post. Nothing worked.

    Finally, I was able to install "ext-gen".

    What I had to do, is sync my sencha support account with the forum account. To do that:

    1) Log in into your sencha support account.
    2) Go to Users section
    3) Double click on the user
    4) Select the "Forum Sync" tab and fill the fields with you forum account.
    Captura de pantalla 2018-10-30 a la(s) 17.44.18.jpg
    5) After saving, I was able to run "npm install -g @sencha/ext-gen" without errors.

    Hope this helps!

  4. #14

    Default can someone help me?

    Its not worked for me... can someone help me?
    Quote Originally Posted by emilianosuarez View Post
    I had the same issue and I tried all the solutions of this post. Nothing worked.Finally, I was able to install "ext-gen".What I had to do, is sync my sencha support account with the forum account. To do that:1) Log in into your sencha support account.2) Go to Users section3) Double click on the user4) Select the "Forum Sync" tab and fill the fields with you forum account.Captura de pantalla 2018-10-30 a la(s) 17.44.18.jpg5) After saving, I was able to run "npm install -g @sencha/ext-gen" without errors.Hope this helps!

  5. #15
    Ext Support Team
    Join Date
    Jan 2018
    Posts
    469
    Vote Rating
    -334
      0  

    Default

    Hi,

    Could you please try resetting the npm and follow the below steps to fix the 403 errors:
    These steps could be used to reset the NPM system.

    1. Run rm ~/.npmrc - removes the stored npm repository credentials. This locaiton may be different on your system.
    2. Run npm cache clean --force or rm -rf ~/.npm - clean the npm packages cache by removing it.
    3. Run npm login --registry=http://npm.sencha.com [email protected] - log back into the repository.
    4. Run npm install -g @sencha/ext-gen or npm install -g @sencha/ext-react-gen

    403 Errors

    When authorization errors show up on npm.sencha.com.

    1. Run npm login --registry=http://npm.sencha.com [email protected] and login to the npm repo again.
    2. Run npm --registry http://npm.sencha.com whoami testing your athorization.
    3. Run npm install -g @sencha/ext-gen or npm install -g @sencha/ext-react-gen to verify that your logged in.

  6. #16

    Join Date
    Dec 2017
    Location
    Chicago
    Posts
    1
    Vote Rating
    0
      0  

    Default

    I reset the NPM system. Then I ran npm login and ran the whoami. However when I tried to install ext-gen, I still got the 403 error.

  7. #17

    Default

    Hi guys,


    I had installed the Sencha ExtGen v1.0.1 version and I was not able to generate new apps, I got this issue:


    (node:60581) UnhandledPromiseRejectionWarning: Error: Cannot find module '.../node_modules/@sencha/ext/package.json'
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:580:15)
    at Function.Module._load (internal/modules/cjs/loader.js:506:25)
    at Module.require (internal/modules/cjs/loader.js:636:17)
    at require (internal/modules/cjs/helpers.js:20:18)
    at stepCreate (/.../.nvm/versions/node/v10.12.0/lib/node_modules/@sencha/ext-gen/ext-gen.js:519:22)
    at process._tickCallback (internal/process/next_tick.js:68:7)
    (node:60581) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
    (node:60581) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.


    So here you are what I did to fix this issue:

    I went to the Sencha's website and I started a trial Ext JS Community Edition - I entered the form and then received an e-mail: "Sencha, Inc. gave you access to the community feed on MyGet"

    In the past I had created an account for MyGet Repository. https://sencha.myget.org/Account/Login

    So I noticed that in the ExtJS 6.6.0-CE docs, the repository's url is:

    npm login --registry=https://sencha.myget.org/F/community/npm/ [email protected]

    So with the MyGet account, I logged into the repository, and I ran the command:

    npm install -g @sencha/ext-gen


    This command installed successfully the @sencha/[email protected] version and now I'm able to create new apps using the Open Tooling.

    I hope this can help someone.

  8. #18
    Sencha User
    Join Date
    Jun 2018
    Posts
    11
    Vote Rating
    0
      0  

    Default

    It sais to me: "No access token provided."

    I don't know if maybe my boss did something to the account because you provided really horrible support so we wanted to end the license.

    I advice people never use sencha products. I regret so much.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Installing sencha sdk tool on linux system
    By sandeepmnit35 in forum Sencha Touch 2.x: Discussion
    Replies: 0
    Last Post: 6 Feb 2013, 9:29 PM
  2. Replies: 0
    Last Post: 4 Jun 2010, 7:03 AM
  3. Automatically open a tool item on render?
    By abcdef in forum Ext 3.x: Help & Discussion
    Replies: 1
    Last Post: 17 May 2010, 10:03 AM
  4. ExtJS not working after installing URLScan tool
    By mohd_osman in forum Ext 2.x: Help & Discussion
    Replies: 1
    Last Post: 17 Jul 2009, 9:02 AM
  5. Any open source tool to remove unwanted characters from JavaScript?
    By msuresh in forum Ext 2.x: Help & Discussion
    Replies: 2
    Last Post: 24 Jan 2008, 4:54 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •