Results 1 to 3 of 3

Thread: 'npm run build-desktop-production' fails for project generated with ext-gen

  1. #1
    Sencha Premium User
    Join Date
    Jun 2015
    Vote Rating

    Exclamation 'npm run build-desktop-production' fails for project generated with ext-gen

    The 'ext-gen' app appears to generate applications that cannot be built in production-mode (i.e. it can only be run in dev mode with e.g. "npm start" or "npm run desktop", not with "npm run build-desktop-production" . Steps to reproduce:
    ext-gen app --classictheme theme-graphite -n ClassicApp
    cd classic-app
    npm run build-desktop-production
    The error message I get is:
    (node:34668) UnhandledPromiseRejectionWarning: #<Object>(node:34668) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
    (node:34668) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.
    Do anyone else see the same behaviour?

  2. #2
    Sencha Premium User
    Join Date
    Dec 2010
    Vote Rating


    I just tried this and got the same error.

  3. #3
    Ext Support Team
    Join Date
    Sep 2017
    Vote Rating



    Thank you for reporting this issue!

    We are looking into this and we will get back you

Similar Threads

  1. Cmd production build fails, testing build works
    By bhutten in forum Sencha Cmd
    Replies: 5
    Last Post: 1 Jul 2015, 3:33 AM
  2. How to produce a production build of generated Architect code?
    By parky128 in forum Sencha Architect 2.x: Help & Discussions
    Replies: 0
    Last Post: 18 Nov 2013, 6:59 AM
  3. [OPEN] CMD production build fails due to .SVN
    By danderson in forum Sencha Cmd
    Replies: 7
    Last Post: 21 May 2013, 10:33 AM
  4. [CLOSED] Ext.JS 4.1.1, CMD 3.0.0 - generated app fails to build app (as generated)
    By Uri Dor @ MediaMind in forum Sencha Cmd
    Replies: 1
    Last Post: 6 Feb 2013, 5:57 AM
  5. [FIXED] production build on linux fails
    By bobpardoe in forum Sencha Touch 2.x: Bugs
    Replies: 3
    Last Post: 25 Apr 2012, 5:37 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts