Results 1 to 3 of 3

Thread: 'ext-gen' does not work with multi-app workspaces

  1. #1
    Sencha Premium User
    Join Date
    Jun 2015
    Posts
    4
    Vote Rating
    1
      1  

    Exclamation 'ext-gen' does not work with multi-app workspaces

    How can I make the new "Open Tooling" work with multi-app workspaces?

    Assume that I run the following commands to create a new workspace and one application in it:
    Code:
    sencha generate workspace TestWorkspace
    cd TestWorkspace
    sencha -sdk /path/to/ext-6.6.0 generate app SenchaCmdApp SenchaCmdApp
    If I then run "ext-gen upgrade" in the workspace folder, I get the error
    Code:
    no such file or directory, open 'app.json'
    If I instead run "ext-gen upgrade" in the SenchaCmdApp application folder, I get the error
    Code:
    no such file or directory, lstat 'workspace.json'
    From these error codes and from looking at the code for "ext-gen upgrade", it appears that "ext-gen upgrade" is not designed to handle multi-app workspaces.

    I also tried to manually do the steps "ext-gen upgrade" was not able to perform and then run
    Code:
    npm install
    npm start
    Which results in
    Code:
    Error: ENOENT: no such file or directory, scandir './packages'
    Have I missed some documentation for using "Open Tooling" with multi-app workspaces? And when/how can I replace the use of "Sencha Cmd Packages" with npm packages?

  2. #2
    Sencha User
    Join Date
    Sep 2016
    Posts
    6
    Vote Rating
    0
      0  

    Default

    Same problem here. Did you solve this?

    Best regards
    Maurice

  3. #3
    Sencha Premium User
    Join Date
    Jun 2015
    Posts
    4
    Vote Rating
    1
      0  

    Default

    Quote Originally Posted by Maurice.Rossi View Post
    Same problem here. Did you solve this?

    Best regards
    Maurice
    Hi Maurice,

    Nope, I'm not able to get the "Open Tooling" to work with my setup (Sencha workspace containing ExtJS app folder and package folder). After looking at the ext-gen and ext-build node modules, I don't believe that Sencha expected that to work either. But I did expect Sencha to acknowledge that this is a limitation/bug in the current version (as they did with the other ext-gen issue I reported).

    Even if Sencha has not labeled it as such now, I think you should consider the current "Open Tooling" support as "early access" (as it was originally labeled in this roadmap: https://www.sencha.com/blog/sencha-p...oadmap-update/).

Similar Threads

  1. [DUP] SA 3.1 does not work with workspaces
    By Roman Tngi in forum Sencha Architect 3.x: Bugs
    Replies: 1
    Last Post: 13 Aug 2014, 2:05 AM
  2. [INFOREQ] Multi Level associations doesn't work.
    By jonathansimmons in forum Sencha Touch 2.x: Bugs
    Replies: 2
    Last Post: 19 May 2012, 12:14 PM
  3. mode:'MULTI' of the List doesn't work?
    By ksdl in forum Sencha Touch 2.x: Q&A
    Replies: 1
    Last Post: 24 Mar 2012, 3:05 PM
  4. CSS3 Multi-Column feature with scrollTo function does not appear to work
    By cavalleydude in forum Sencha Touch 1.x: Discussion
    Replies: 3
    Last Post: 1 Jun 2011, 2:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •