Results 1 to 2 of 2

Thread: Ext.Viewport.setMasked(false) fails

    You found a bug! We've classified it as EXTJS-27603 . We encourage you to continue the discussion and to find an acceptable workaround while we work on a permanent fix.
  1. #1
    Touch Premium Member
    Join Date
    Sep 2011
    Posts
    99

    Default Ext.Viewport.setMasked(false) fails

    Ext version tested:

    • Ext 6.6.0.258 Modern

    Browser versions tested against:

    • Chrome 67.0.3396.99 (Official Build) (64-bit)

    Description:

    • Ext.Viewport.setMasked(false) throws a TypeError

    Steps to reproduce the problem:

    • Create a Mask for the Viewport
    • Ext.Viewport.setMasked(false)

    The result that was expected:

    • Mask would disappear

    The result that occurs instead:

    • Uncaught TypeError: Failed to execute 'appendChild' on 'Node': parameter 1 is not of type 'Node'.

    Workaround
    Code:
    if (Ext.Viewport.getMasked()) {
        Ext.Viewport.getMasked().destroy();
    }

  2. #2
    Sencha Staff
    Join Date
    Sep 2017
    Posts
    126

    Default

    Thanks for the report! I have opened a bug in our bug tracker.

Similar Threads

  1. [OPEN] [BUG] [6.5.1] --web-server Fails when set to false
    By bryall in forum Sencha Cmd
    Replies: 4
    Last Post: 24 Aug 2018, 5:29 AM
  2. [FIXED] LoadMask listeners are not passed to Viewport.setMasked() (2.0.1)
    By wirtsi in forum Sencha Touch 2.x: Bugs
    Replies: 4
    Last Post: 7 Dec 2012, 5:18 AM
  3. Replies: 8
    Last Post: 27 Feb 2012, 4:25 PM
  4. Ext.decode() fails on Python's 'False'
    By ZooKeeper in forum Ext 1.x: Help & Discussion
    Replies: 4
    Last Post: 31 Oct 2007, 4:08 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •