Results 1 to 2 of 2

Thread: require() will be deprecated Use @import instead

  1. #1
    Roberto Lopez's Avatar
    Join Date
    Feb 2016
    Location
    Dallas Texas USA
    Posts
    12
    Answers
    3
    Vote Rating
    0
      0  

    Default Answered: require() will be deprecated Use @import instead

    Using ext.version.number=6.0.1.250, Sencha Cmd v6.5.3.6, I have setup a workspace

    Creating app

    c:\extjs\labs\sencha -sdk ..\ext generate app MyApp lab023

    Generates warning:

    [WRN] Use of 'require()' will be deprecated: C:/extjs/ext/classic/theme-neutral/sass/etc/mixins/font-icon.scss:1
    [WRN] Use @import instead

    I made the sugested change from require('font-icon'); to @import 'font-icon';

    I am getting an error after building.


  2. Replacing From:
    require('font-icon');

    To:
    @import 'font-icon.js';

  3. #2
    Roberto Lopez's Avatar
    Join Date
    Feb 2016
    Location
    Dallas Texas USA
    Posts
    12
    Answers
    3
    Vote Rating
    0
      0  

    Default

    Replacing From:
    require('font-icon');

    To:
    @import 'font-icon.js';

Similar Threads

  1. require() will be deprecated Use @import instead
    By Roberto Lopez in forum Ext 6: Q&A
    Replies: 1
    Last Post: 16 Aug 2018, 12:08 PM
  2. require() will be deprecated Use @import instead
    By Roberto Lopez in forum Ext 6: Q&A
    Replies: 1
    Last Post: 16 Aug 2018, 12:07 PM
  3. Replies: 3
    Last Post: 2 Jul 2012, 4:09 AM
  4. Replies: 2
    Last Post: 17 May 2012, 1:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •