Results 1 to 3 of 3

Thread: Upgrade Extjs 5 to 6 theme error

  1. #1
    Sencha User
    Join Date
    Dec 2015
    Posts
    14

    Default Upgrade Extjs 5 to 6 theme error

    Hi, after upgrade to ExtJS 6 from ExtJS 5 I got this error:

    Code:
    [ERR]Cannot satisfy requirements for "theme-crisp"!
    [ERR]The following versions cannot be satisfied:
    [ERR]theme-crisp-d2e330e8-78e5-444b-b1cb-985c140aff5d: theme-crisp (No matches!)
    
    I've the correct theme folder in approot/packages/local (theme-crisp-d2e330e8-78e5-444b-b1cb-985c140aff5d). In the same folder I've the old one (ext-theme-crisp-d2e330e8-78e5-444b-b1cb-985c140aff5d)

    In my app.json I've: "theme": "theme-crisp-d2e330e8-78e5-444b-b1cb-985c140aff5d"
    And in approot/packages/local/theme-crisp-d2e330e8-78e5-444b-b1cb-985c140aff5d/package.json I've "name": "theme-crisp-d2e330e8-78e5-444b-b1cb-985c140aff5d"

    But the app doesn't load any stylesheet... What's wrong?

    Thanks
    Stefano

  2. #2
    Sencha - Forum Administrator
    Join Date
    Sep 2017
    Posts
    1,006
    Answers
    5

    Default

    Hi Stefano- I am sorry you are having trouble with this. I will send this over to the support team to look into. They will be in touch at their earliest convenience. We appreciate your patience!

    Thanks,
    Michele

  3. #3
    Sencha Premium User dawesi's Avatar
    Join Date
    Mar 2007
    Location
    Melbourne, Australia (aka GMT+10)
    Posts
    1,208
    Answers
    26

    Default

    If you haven't customised the theme, maybe try removing the theme and re-adding it to the project in SA.
    Cloud Application Architect

    Sencha Specialist / Sencha MVP
    ExtJs Developer + Contributor since 0.2.2 - Champion of the per developer license.

Similar Threads

  1. Error after upgrade to ExtJS 4.2.3
    By alexvazquez in forum Ext: Q&A
    Replies: 12
    Last Post: 11 Jul 2016, 1:07 AM
  2. Upgrade from ExtJS 5 to 6 - custom theme not being picked up
    By lmastrodicasa in forum Ext JS 6.x Q&A
    Replies: 7
    Last Post: 18 Nov 2015, 7:30 AM
  3. Extjs 6.0.1 upgrade error
    By sahiltanta in forum Ext JS 6.x Q&A
    Replies: 4
    Last Post: 24 Sep 2015, 9:35 AM
  4. [CLOSED] I got an error in my app . Theme is not found after upgrade.
    By marogalli in forum Sencha Architect 3.x: Bugs
    Replies: 3
    Last Post: 24 Feb 2014, 9:25 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •