Results 1 to 2 of 2

Thread: CMD errors on build

  1. #1

    Default CMD errors on build

    Hi there, I keep get a WARN and ERR while building my application with `sencha app build`.

    First error is;

    [ERR] java.lang.RuntimeException: Exception parsing "compression-input"
    [ERR]     at java.lang.reflect.
    [ERR] Method.invoke(
    [ERR] Total time: 42 seconds
    [ERR] /Users/frontend/bin/Sencha/Cmd/ The following error occurred while executing this line:
    /Users/frontend/bin/Sencha/Cmd/ The following error occurred while executing this line:
    /Users/frontend/bin/Sencha/Cmd/ java.lang.RuntimeException: Exception parsing "compression-input"
    [ERR] A log is available in the file "/Users/frontend/Dev/webex/oweb/sencha-error-20181011-2.log"
    Here is all LOG file @

    And also I keep face a this warn while I tried to solve issue above;
    [WRN] the following remote package repository directories did not initialize properly :
    [WRN]      - /Users/frontend/bin/Sencha/Cmd/repo/.sencha/repo/remotes/.DS_Store
    I've research through Google/Sencha Forums/Stackoverflow for a proper solution or understanding reason for the Error. I've found only a way on CMD documents which says disable transpiler. I did it but then CMD stucks on on line: `JavaScript input level is NEXT and output level is ES5` also doesn't throw error.
    And I've reached several Post on here for WARN which advices giving permission to `catalog.json` in Sencha/CMD/repo folder and I did but still warn continues.
    Here is app.json @

    What could be reason for `[ERR] java.lang.RuntimeException: Exception parsing "compression-input"` error?
    Thanks in advance.

    + There is no error during `sencha app build --development`, `sencha app refresh`

    - MacOS Sierra v10.12.6
    - Java 8 Update 181
    - Sencha CMD v6.6.013
    - ExtJS 6.5.2
    - Sencha Architect

    What I've tried to overcome [ERR]:
    - Setting JS "output" to ES6. Still CMD stucks on `[INF] JavaScript input level is NEXT and output level is ES6` @
    "output": {
        "base": "${}/${build.environment}/${}/${}",
        "page": "../index.html",
        "manifest": "../${}.json",
        "appCache": {
            "enable": false
        "js": {
            "version": "ES6"
    - Tried to increase Java Heap @
    + increase heap arg on `sencha.cfg @
    Still stucks on `[INF] JavaScript input level is NEXT and output level is ES6` after increase adjustment on System Preference>Java and sencha.cfg

  2. #2


    First I've deleted `/Users/foo/bin/Sencha/` and re-installed CMD again.
    Then I gone to `/Users/foo/bin/Sencha/Cmd/` and refactored `sencha.vmoptions` file as;

    # Enter one VM parameter per line
    # For example, to adjust the maximum memory usage to 512 MB, use the following line:
    # -Xmx512m
    # To include another file, uncomment the following line:
    # -include-options [path to other .vmoption file]
    This solved issue for both [WARN] and compiler error.

Similar Threads

  1. Build errors using sencha cmd
    By vikrant.verma in forum Sencha Cmd
    Replies: 1
    Last Post: 26 Jul 2015, 8:06 AM
  2. Replies: 5
    Last Post: 21 Apr 2015, 4:31 PM
  3. ERRORS after build!
    By taron133 in forum Sencha Cmd
    Replies: 3
    Last Post: 16 Jan 2015, 6:55 AM
  4. So many errors on build..HELP
    By sagoig in forum Sencha Cmd
    Replies: 5
    Last Post: 4 Oct 2013, 9:45 AM
  5. Errors in app after build
    By kryptomens in forum Sencha Touch 2.x: Q&A
    Replies: 4
    Last Post: 27 Jul 2012, 7:29 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts