Results 1 to 10 of 10

Thread: ExtReact 6.6.3 npm start failed to compile error...

  1. #1
    Sencha Premium User
    Join Date
    Dec 2014
    Posts
    9

    Default ExtReact 6.6.3 npm start failed to compile error...

    I used ext-react-gen to generate the project, then npm start, but the following error occurred, how can I solve it?? Thanks.

    extreact.jpg

  2. #2
    Sencha Premium Member ebett's Avatar
    Join Date
    Nov 2010
    Location
    Argentina
    Posts
    31
    Answers
    1

    Default

    Quote Originally Posted by daniel.lee View Post
    I used ext-react-gen to generate the project, then npm start, but the following error occurred, how can I solve it?? Thanks.

    extreact.jpg
    I have the same problem
    c:\TEMP\app>npm start

    > [email protected] start c:\TEMP\app
    > npm run dev


    > [email protected] dev c:\TEMP\app
    > webpack-dev-server --env.verbose=no --env.environment=development

    i [ext]: ext-webpack-plugin v6.6.3, Ext JS v6.6.0.258 Commercial Edition, Sencha Cmd v6.6.0.13, webpack v4.27.1, react v16.6.3
    i [ext]: Building for development
    i 「wds」: Project is running at http://0.0.0.0:1962/
    i 「wds」: webpack output is served from /
    i 「wds」: Content not from webpack is served from ./build
    i 「wds」: 404s will fallback to /index.html
    ℹ 「ext」: ext-react-babel-plugin: reactVersion: ^16.6.3
    i [ext]: Adding ext-react\ext.js and ext-react\ext.css to index.html
    i [ext]: Copying \resources\ to: \build\resources
    i [ext]: Copying \resources\ to: \build\ext-react\resources
    i [ext]: Building Ext bundle at: \build\ext-react
    i [ext]: [ERR] Directory \build\ext-react\node_modules\@sencha\ext not recognized as a framework
    i [ext]: [ERR] Unable to load required framework: [email protected]

    i [ext]: Completed ext-webpack-plugin processing
    × 「wdm」: Built at: 2018-12-07 12:26:34
    Entrypoint app = app.js app.js.map

    ERROR in i [ext]: Directory \build\ext-react\node_modules\@sencha\ext not recognized as a framework

    ERROR in i [ext]: Unable to load required framework: [email protected]


    ERROR in 321
    i 「wdm」: Failed to compile.

  3. #3
    Sencha Premium Member ebett's Avatar
    Join Date
    Nov 2010
    Location
    Argentina
    Posts
    31
    Answers
    1

    Default

    Quote Originally Posted by daniel.lee View Post
    I used ext-react-gen to generate the project, then npm start, but the following error occurred, how can I solve it?? Thanks.

    extreact.jpg
    I followed the 6.5 guide and it works!

    npm install -g yo @extjs/generator-ext-react
    yo @extjs/ext-react
    ...
    npm start

  4. #4
    Sencha Premium User
    Join Date
    Dec 2014
    Posts
    9

    Default

    Quote Originally Posted by ebett View Post
    I followed the 6.5 guide and it works!

    npm install -g yo @extjs/generator-ext-react
    yo @extjs/ext-react
    ...
    npm start
    After npm login --registry=https://npm.sencha.com [email protected]
    then run :npm install -g yo @extjs/generator-ext-react , another error occurred....
    ---------------------------------------------------------------------------------------

    PS C:\E\Project\MManager 1.2\mmanager> npm install -g yo @extjs/generator-ext-react
    npm ERR! code E403
    npm ERR! 403 Forbidden: @extjs/[email protected]


    npm ERR! A complete log of this run can be found in:
    ---------------------------------------------------------------------------------------

  5. #5
    Sencha Premium Member ebett's Avatar
    Join Date
    Nov 2010
    Location
    Argentina
    Posts
    31
    Answers
    1

    Default

    Quote Originally Posted by daniel.lee View Post
    After npm login --registry=https://npm.sencha.com [email protected]
    then run :npm install -g yo @extjs/generator-ext-react , another error occurred....
    ---------------------------------------------------------------------------------------

    PS C:\E\Project\MManager 1.2\mmanager> npm install -g yo @extjs/generator-ext-react
    npm ERR! code E403
    npm ERR! 403 Forbidden: @extjs/[email protected]


    npm ERR! A complete log of this run can be found in:
    ---------------------------------------------------------------------------------------
    Try with [email protected]

  6. #6
    Sencha Premium User
    Join Date
    Dec 2014
    Posts
    9

    Default

    npm login --registry=https://npm.sencha.com [email protected]

    npm ERR! code E503
    npm ERR! Registry returned 503 for POST on https://npm.sencha.com/-/v1/login


    npm ERR! A complete log of this run can be found in:

  7. #7
    Sencha Premium User
    Join Date
    Dec 2014
    Posts
    9

    Default

    >npm install -g yo @extjs/generator-ext-react
    npm ERR! code E403
    npm ERR! 403 Forbidden: @extjs/[email protected]


    npm ERR! A complete log of this run can be found in:
    --------------------------------

    No permission to access @extjs/[email protected], maybe my account problem.. Thanks for your response.

  8. #8

    Default

    Did someone make it run?

  9. #9
    Sencha Premium User
    Join Date
    Sep 2017
    Posts
    4

    Default

    I've solved this issue by installing webpack-plugin 6.6.0 and babel-polyfill.

    npm install --save-dev @sencha/[email protected]
    npm install --save-dev babel-polyfill

  10. #10

    Default

    That solution works like a charm

Similar Threads

  1. I failed to start the ExtReact kitchen Sink
    By Mark.Brocato in forum Q&A
    Replies: 0
    Last Post: 10 Jul 2017, 6:00 AM
  2. Replies: 2
    Last Post: 19 May 2017, 9:20 AM
  3. Replies: 2
    Last Post: 10 Dec 2012, 6:18 AM
  4. Replies: 0
    Last Post: 10 Dec 2012, 2:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •