Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: How to build bootstrap files from extjs modern npm package?

  1. #1
    Sencha User
    Join Date
    Oct 2013
    Posts
    47
    Answers
    1

    Default How to build bootstrap files from extjs modern npm package?

    Hi.
    Is it possible to build extjs framework bootstrap files from @sencha/ext-modern npm package?
    Previously I can did this downloading extjs in archive and executing "sencha ant bootstrap".
    But it is unclear, how I can achieve this with npm.
    Does somebody can help?

  2. #2
    Sencha - Forum Administrator
    Join Date
    Sep 2017
    Posts
    1,006
    Answers
    5

    Default

    Thank you so much for your post. I apologize for the delay. I have shared this with the support staff to look into at their earliest convenience. Your patience is greatly appreciated! We do suggest using the support portal when you need assistance with a capability of a Sencha product, you have identified a situation where a products behavior is inconsistent with the product documentation and might indicate a software bug, or when the communication between you and Sencha needs to be private.

    Thanks again,

    Michele



  3. #3
    Ext Support Team
    Join Date
    Jan 2018
    Posts
    569
    Answers
    7

    Default

    Hi,

    We reached out to Architect team and please find their inputs -

    " They can still use sencha through the npm packages by using "npx" like this: "npx sencha ant bootstrap". NPX allows you to use binaries included in NPM modules directly "

    Regards,
    Kumar.

  4. #4
    Sencha User
    Join Date
    Oct 2013
    Posts
    47
    Answers
    1

    Default

    I got an error.

    d:\devel\nodejs\node_modules\@sencha\ext-modern>npx sencha ant bootstrap
    Wat!
    configFile: d:\devel\nodejs\node_modules\@sencha\cmd\dist\sencha.cfg
    Sencha Cmd v6.6.1.34
    [ERR] Cannot satisfy requirements for "core"!
    [ERR] The following versions cannot be satisfied:
    [ERR] modern: core (No matches!)
    [INF] Loading compiler context
    [ERR] Cannot satisfy requirements for "core"!
    [ERR] The following versions cannot be satisfied:
    [ERR] modern: core (No matches!)
    [ERR]
    [ERR] BUILD FAILED
    [ERR] com.sencha.exceptions.ExVersion: Cannot resolve package requirements
    [ERR]
    [ERR] Total time: 2 seconds


    [ERR] d:\devel\nodejs\node_modules\@sencha\ext-modern\build.xml:159: com.sencha.exceptions.ExVersion: Cannot resolve package requirements
    [ERR] Cannot satisfy requirements for "core"!
    [ERR] The following versions cannot be satisfied:
    [ERR] modern: core (No matches!)
    [ERR] A log is available in the file "D:\devel\nodejs\node_modules\@sencha\ext-modern\sencha-error-20190221.log"

  5. #5
    Ext Support Team
    Join Date
    Jan 2018
    Posts
    569
    Answers
    7

    Default

    Hello,

    Download and install bootstrap library from npm’s public repository.


    npm install bootstrap


    Open the editor and expand the “node_modules” folder. Look for bootstrap folder and choose the minified js file that you want to use.
    Add its path to “js” array in app.json


    Code:
    "js": [
    {
    "path": "app.js",
    "bundle": true
    },
    {
    "path": "node_modules/bootstrap/dist/js/bootstrap.min.js"
    }
    ],


    Reference Lnk: https://medium.com/@walkingtreetech/...g-9d59e74a3b9d

    Regards,
    Kumar
    Sencha Support.

  6. #6
    Sencha User
    Join Date
    Apr 2013
    Posts
    914
    Answers
    105

    Default

    Quote Originally Posted by rakumar View Post
    Download and install bootstrap library from npm’s public repository.
    npm install bootstrap
    You have no idea what zdm is asking, do you? Twitter Bootstrap has nothing to do with his question...

  7. #7
    Sencha User
    Join Date
    Sep 2007
    Location
    Phoenix AZ
    Posts
    121
    Answers
    5

    Default

    @rakumar - Answered like someone with some javascript experience but has never used the Sencha tools.

  8. #8
    Ext Support Team
    Join Date
    Jan 2018
    Posts
    569
    Answers
    7

    Default

    Please accept our apologies.

    We are currently working with Product Architect on this issue and will keep this thread posted with an update at earliest possible.

    Thank you for your continued support.

    Regards,
    Kumar.

  9. #9
    Ext Support Team
    Join Date
    Jan 2018
    Posts
    569
    Answers
    7

    Default

    Hi,

    Just wanted to let you know that your feedback [error message/code] was shared with Product Architect. While we discuss further on this, may I ask you to share the log files so I can send over to Product Architect for further investigation.

    Thanks for looking into this.

    Regards,
    Kumar.

  10. #10
    Ext Support Team
    Join Date
    Jan 2018
    Posts
    569
    Answers
    7

    Default

    Hi,

    Also -

    While you provide the log files to us, please try to build a app in development version [this uses bootstrapping functionality as well] and see if you get same error? Please keep us informed about this as well.

    Appreciate your time.

    Regards,
    Kumar.

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 4
    Last Post: 22 Mar 2019, 10:15 AM
  2. Replies: 1
    Last Post: 25 Jan 2019, 3:06 AM
  3. Ext 6.5 -Unable to build app using package having modern component
    By siddharth-arvan in forum Ext JS 6.x Q&A
    Replies: 3
    Last Post: 2 Jul 2017, 10:35 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •