Results 1 to 9 of 9

Thread: Sencha Architect 4.2.5 is Available

  1. #1
    Sencha Premium User
    Join Date
    Jun 2014
    Posts
    6

    Default Sencha Architect 4.2.5 is Available

    Where is the documentation?
    What are the news?
    What bugs have been fixed?
    Last edited by corucci; 13 Mar 2019 at 5:50 AM. Reason: Info

  2. #2
    Sencha Premium User
    Join Date
    Sep 2016
    Location
    Germany
    Posts
    37
    Answers
    1

    Default

    And how to upgrade the used ExtJS version of a project to 6.7?

  3. #3
    Sencha Premium User
    Join Date
    Sep 2016
    Location
    Germany
    Posts
    37
    Answers
    1

    Default

    Quote Originally Posted by corucci View Post
    Where is the documentation?
    What are the news?
    What bugs have been fixed?
    https://docs.sencha.com/architect/4/...hange_log.html
    Hasn't been updated in a while...
    But there's an official announcement in the blog.
    https://www.sencha.com/blog/announci...oling-updates/
    The listed new features are support for ExtJS 6.7 and Grid Filtering, Locking Grid, Multiselect Combobox and Color Picker.
    It's not mentioned to which version - classic or modern - they apply.

    Quote Originally Posted by clampart View Post
    And how to upgrade the used ExtJS version of a project to 6.7?
    First let Architect 4.2.5 upgrade the project - this will only affect SenchaCMD.
    After that, close Architect.
    Then in your $project.xds file change "settings.cmd.frameworkVersion" to "6.7.0.212" and "framework" to "ext67".
    Open the project in Architect and do "File" -> "Save entire Project".
    Voila! Your project now uses ExtJS 6.7!

  4. #4
    Sencha Premium User
    Join Date
    Dec 2010
    Posts
    279
    Answers
    8

    Default

    Quote Originally Posted by clampart View Post
    https://docs.sencha.com/architect/4/...hange_log.html
    Hasn't been updated in a while...
    But there's an official announcement in the blog.
    https://www.sencha.com/blog/announci...oling-updates/
    The listed new features are support for ExtJS 6.7 and Grid Filtering, Locking Grid, Multiselect Combobox and Color Picker.
    It's not mentioned to which version - classic or modern - they apply.



    First let Architect 4.2.5 upgrade the project - this will only affect SenchaCMD.
    After that, close Architect.
    Then in your $project.xds file change "settings.cmd.frameworkVersion" to "6.7.0.212" and "framework" to "ext67".
    Open the project in Architect and do "File" -> "Save entire Project".
    Voila! Your project now uses ExtJS 6.7!
    Your instructions do not actually upgrade a project. Look in your project folder ext/build and old framework is still there. This is what is used when building.

  5. #5
    Sencha Premium Member
    Join Date
    Mar 2016
    Location
    Italy
    Posts
    42

    Default Sencha Architect 4.2.5 is really avaiable??

    Quote Originally Posted by tomdchi View Post
    Your instructions do not actually upgrade a project. Look in your project folder ext/build and old framework is still there. This is what is used when building.
    I updated SA and my project using this guide (I opened a ticket in support)

    Hello Alessio,

    You can update your application either via Sencha Architect or the CLI
    Check out the following video starting @ ~3:30.
    https://www.youtube.com/watch?v=fL6jkO0y754

    I would recommend doing it via Sencha Architect.
    Please note this will not update the framework version in your applications 'About Sencha Architect' window.
    The only problem is that after the update, the SA toolbox refer to extjs 6.6.x .
    So you can't use the new extjs 6.7.0 components.

    Is this normal? I think no, but, what can we do with this?

    Alessio.

  6. #6
    Sencha Premium User
    Join Date
    Dec 2010
    Posts
    279
    Answers
    8

    Default

    Quote Originally Posted by Alessio Brunello View Post
    I updated SA and my project using this guide (I opened a ticket in support)



    The only problem is that after the update, the SA toolbox refer to extjs 6.6.x .
    So you can't use the new extjs 6.7.0 components.

    Is this normal? I think no, but, what can we do with this?

    Alessio.
    I opened a ticket as well and got the same response. After I inquired further, the support person figured out that there is a bug in the latest version of Architect that is not allowing a project to upgrade the framework. I wouldn't count on a fix any time soon.

  7. #7
    Sencha Premium Member
    Join Date
    Mar 2016
    Location
    Italy
    Posts
    42

    Default

    Quote Originally Posted by tomdchi View Post
    I opened a ticket as well and got the same response. After I inquired further, the support person figured out that there is a bug in the latest version of Architect that is not allowing a project to upgrade the framework. I wouldn't count on a fix any time soon.

    What a good news...
    I hope in something better from them..

  8. #8
    Sencha Premium User
    Join Date
    Dec 2010
    Posts
    279
    Answers
    8

    Default

    Quote Originally Posted by Alessio Brunello View Post
    What a good news...
    I hope in something better from them..
    I posted a workaround here. Hope it helps.

  9. #9
    Sencha Premium User dawesi's Avatar
    Join Date
    Mar 2007
    Location
    Melbourne, Australia (aka GMT+10)
    Posts
    1,242
    Answers
    26

    Default

    - no class off application node (as promised)
    - no fix for 'dealbreaker' Tabpanel sass bug so you can't change theme or blow up your whole project metadata - are you seriously releasing a product that blows up still on a simple colour change to tabpanel? This should be priority #1
    - still no profiles support, dashboads, dnd,
    - also no upgrade path in SA for classic projects. SA doesn't ask if I want to upgrade to 6.7 for classic, only modern.

    this is 4.2.44 not 4.2.5 - no new features of use anywhere in the product - upgrading just the ExtJS version without adding the 20+ missing components already in 6.6 is proof Idera's Sench's dev team are not capable of delivering.

    are they sitting around drinking coffee, as they've done NOTHING useful in this release.

    What a disgrace.
    Cloud Application Architect

    Sencha Specialist / Sencha MVP / Sencha Technical Trainer
    ExtJs Developer + Contributor since 0.2.2 - Champion of the per developer license.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •