Results 1 to 2 of 2

Thread: How To Upgrade Project Framework in SA 4.2.5

  1. #1
    Sencha Premium User
    Join Date
    Dec 2010
    Posts
    278
    Answers
    8

    Default How To Upgrade Project Framework in SA 4.2.5

    Instructions in the thread here are incomplete. The only thing these instructions do is make SA think your project uses ExtJS 6.7 but it really doesn't.

    Here is what I did to fully upgrade a project from 6.6 to 6.7.

    First part taken from instructions referenced in above link.
    1. Let Architect 4.2.5 upgrade the project - this will only affect the used version of SenchaCMD.
    2. Close Architect
    3. Open <project name>.xds file change "settings.cmd.frameworkVersion" to "6.7.0.212" and "framework" to "ext67". This file is in your project folder and can be edited with any text editor.
    4. Open project in SA.
    5. Go to Edit -> Preferences and select Framework
    6. Click Reinitialize Cmd button. This will replace the framework your project is currently using with 6.7.


    Note: I did this on a project that was currently using 6.6. I do not know if there are any complications doing it this way if framework is an older version.

  2. #2
    Sencha - Forum Administrator
    Join Date
    Sep 2017
    Posts
    1,006
    Answers
    5

    Default

    Thank you so much for your post. I apologize for the delay. I have shared this with the support staff to look into at their earliest convenience. Your patience is greatly appreciated!

    Thanks again,

    Michele


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •