Results 1 to 3 of 3

Thread: "Load Data" failed with Ext JS Architect

  1. #1
    Sencha User
    Join Date
    Mar 2019
    Posts
    4

    Default "Load Data" failed with Ext JS Architect

    Hi,

    I'm new with Ext JS. After installing all the needed software, I'm trying to use Architect to create my first desktop application (i.e. CarListings application) by following the Tutorials provided in Architect 4.2.5.420

    I was able to follow all the way thru step 5. However, at the step 6, it asked to set the url to point to the "data/car.json" and then right click CarDataStore to load data. It failed.

    The only think I could think of that might go wrong is the url setting. What I did was, I downloaded the data file from Git-Hub repository and placed the "data" folder, as per the instruction, in the same directory where the xds is located, i.e. C:\CarListings\data\cars.json. So I set the url of the "CarDataStore" to "data/car.json". However, when I right-clicked to load the data from JSON file, it failed.

    Attached please find the project (CarListings.xda), any tip or info will be greatly appreciated.
    Attached Files Attached Files
    Last edited by ghm; 9 Apr 2019 at 2:03 PM. Reason: Duplicate

  2. #2
    Sencha MVP Team Member
    Join Date
    Sep 2016
    Location
    Kennewick, WA
    Posts
    150
    Answers
    15

    Default

    Can you provide the code (The .xda doesn't help us much and I prefer to not download those file types) you need help with?

    I am guessing at this point, but your problem could be url: 'data/car.json' as it does sound like the issue.

    Without more code the best I can suggest is try

    url: '/data/car.json'
    Andy Allord
    Sencha MVP/Software Engineer

  3. #3
    Sencha User
    Join Date
    Oct 2014
    Posts
    14

    Default

    Hi ghm,

    did you check your browser console? Running your code I get "ext-all-rtl-debug.js?_dc=1555526383437:10375 [E] Ext.data.proxy.Server.buildUrl(): You are using a ServerProxy but have not supplied it with a url."

    For some reason your CarDataStore proxy uses the bind property to supply the proxy url:

    Code:
    bind: {
       url:'data/cars.json'
    },
    
    supplying the url property directly works fine.
    You enabled data binding for the URL property in Architect
    Bildschirmfoto von 2019-04-17 20-58-02.png

    check the little icon in the middle.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •