Results 1 to 2 of 2

Thread: how to build Modern app with classic code( dashboard and checkboxgroup)?

  1. #1
    Sencha User
    Join Date
    Oct 2015
    Posts
    48
    Answers
    1
    Vote Rating
    -1
      0  

    Default how to build Modern app with classic code( dashboard and checkboxgroup)?

    i have Ext.Dashboard.dashboard and Ext.form.CheckboxGroup in my classic model app,right now i'am getting error when build modern app with classic code,anyone can help in that topic?


    Code:
    > Task encha_app
    Sencha Cmd v6.6.0.13
    [INF] Loading compiler context
    [ERR] Failed to resolve dependency Ext.dashboard.Dashboard for file Pltx2.view.body.dashboard.DashboardPanel
    [ERR] Unknown definition for dependency : Ext.dashboard.Dashboard
    [ERR] 
    [ERR] The application was last modified by an older version of Sencha Cmd (6.1.0.65).
    [ERR] Running "sencha app upgrade" may resolve the error described above.
    [ERR] 
    
    
    > Task encha_app FAILED
    
    
    FAILURE: Build failed with an exception.
    
    
    * What went wrong:
    Execution failed for task 'encha_app'.
    > Process 'command '/usr/local/share/sencha/bin/Sencha/Cmd/sencha-latest'' finished with non-zero exit value 65
    Attached Images Attached Images

  2. #2
    Ext JS Premium Member tangix's Avatar
    Join Date
    Mar 2010
    Location
    Stockholm, Sweden
    Posts
    723
    Answers
    10
    Vote Rating
    79
      0  

    Default

    You are out of luck - those components doesn't exist in the modern framework.
    You will have to implement that functionality by yourself or take them out of your project.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •