Results 1 to 5 of 5

Thread: Modern 6.7 Grid error in plugin gridfilters

    Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1

    Default Modern 6.7 Grid error in plugin gridfilters

    Hello
    This error only occurs with remote filters

    *****VIEW*******

    Ext.define('BigData.view.MyGrid', {
    extend: 'Ext.grid.Grid',
    alias: 'widget.mygrid',


    requires: [
    'BigData.view.MyGridViewModel',
    'Ext.grid.column.Column'
    ],


    viewModel: {
    type: 'mygrid'
    },
    height: '100%',
    width: '100%',
    fullscreen: true,
    autoSize: true,
    plugins: {
    type: 'gridfilters'
    },


    bind: {
    store: '{store}'
    },
    columns: [
    {
    xtype: 'gridcolumn',
    width: 308,
    dataIndex: 'NOMBRE',
    filter: {
    type: 'string',
    menu: {
    items: {
    like: {
    placeholder: 'Custom Like...'
    }
    }
    }
    },
    text: 'String'
    }
    ]


    });

    *********VIEWMODEL*****

    Ext.define('BigData.view.MyGridViewModel', {
    extend: 'Ext.app.ViewModel',
    alias: 'viewmodel.mygrid',


    requires: [
    'Ext.data.Store',
    'Ext.data.proxy.Ajax',
    'Ext.data.reader.Json'
    ],


    stores: {
    store: {
    remoteFilter: true,
    autoLoad: true,
    model: 'BigData.model.usuario',
    proxy: {
    type: 'ajax',
    api: {
    read: 'php/susuarios/listar.php'
    },
    reader: {
    type: 'json',
    rootProperty: 'data'
    }
    }
    }
    }


    });

  2. #2
    Ext Support Team
    Join Date
    Jan 2018
    Posts
    542

    Default

    Hello,

    Thank you for contacting Sencha Support!

    I request you to provide a fiddle reproducing the issue to assist you in a better way.

    Regards,
    Kumar
    Sencha Support.

  3. #3

    Default

    Hello Rakumar
    I have attached link and error image with a simple example reproducing the error.
    The error occurs when you set up the store with a remote filter.

    error.png

    https://fiddle.sencha.com/#view/editor&fiddle/2sjh

    Regards,
    Lowconquer

  4. #4
    Ext Support Team
    Join Date
    Jan 2018
    Posts
    542

    Default

    Hello Lowconquer,

    Please see the fiddle below with an override to fix this issue:

    https://fiddle.sencha.com/#view/editor&fiddle/2t8g

    Regards,
    Kumar
    Sencha Support.

  5. #5

    Default

    Rakumar
    Thank you very much for your answer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •