Is JetBrains Plugin compatible with latest IDEA 2019.2 EAP?

It continues to prompt me for my license, and I'm not able to activate it. If I use IDEA 2019.1 RELESE everything works as expected.