Just checked the support portal and cannot see anything later than 7.0.0.131 from July 23.
The latest npm that I managed to get using the cumbersome EA is 7.0.0.116.
What gives?