Results 1 to 9 of 9

Thread: ST 2.3.0 not available in support portal

  1. #1
    Sencha User
    Join Date
    Mar 2017
    Posts
    45

    Default ST 2.3.0 not available in support portal

    I'd like to download the latest 2.3.0 GA release but it's not available in download portal. Please make this available asap.


    I've downloaded the latest nightly build of 2.3.0.317 but I'm receiving the following error just opening the program and actions like .click() a login button aren't occurring:



    C:\Program Files\Sencha\Test\2_3_0_317\resources\app.asar\node_modules\sencha-tern\plugin\ext\lib\config.js:404

    classpath.forEach(function(classpathEntry){

    ^

    TypeError: classpath.forEach is not a function

    at populateAdditionalInfo (C:\Program Files\Sencha\Test\2_3_0_317\resources\app.asar\node_modules\sencha-tern\plugin\ext\lib\config.js:404:19)

    at findToolkit (C:\Program Files\Sencha\Test\2_3_0_317\resources\app.asar\node_modules\sencha-tern\plugin\ext\lib\config.js:383:27)

    at createApp (C:\Program Files\Sencha\Test\2_3_0_317\resources\app.asar\node_modules\sencha-tern\plugin\ext\lib\config.js:328:30)

    at findApps (C:\Program Files\Sencha\Test\2_3_0_317\resources\app.asar\node_modules\sencha-tern\plugin\ext\lib\config.js:291:19)

    at Array.forEach (native)

    at initialize (C:\Program Files\Sencha\Test\2_3_0_317\resources\app.asar\node_modules\sencha-tern\plugin\ext\lib\config.js:97:51)

    at module.exports (C:\Program Files\Sencha\Test\2_3_0_317\resources\app.asar\node_modules\sencha-tern\plugin\ext\lib\config.js:83:12)

    at Object.postReset (C:\Program Files\Sencha\Test\2_3_0_317\resources\app.asar\node_modules\sencha-tern\plugin\ext.js:120:31)

    at Object.signal (C:\Program Files\Sencha\Test\2_3_0_317\resources\app.asar\node_modules\sencha-tern\lib\signal.js:28:49)

    at Object.reset (C:\Program Files\Sencha\Test\2_3_0_317\resources\app.asar\node_modules\sencha-tern\lib\tern.js:154:12)

    Task "Code Completion Service" <br> exited with code : 1

  2. #2
    Sencha - Sales Team daniel.gallo's Avatar
    Join Date
    Apr 2009
    Location
    Redwood City, CA
    Posts
    326
    Answers
    49

    Default

    Thanks for the report. Version 2.3 should be available in the Support Portal later today. I'll follow up once it's available.

    In the meantime, if you request a new trial of Sencha Test (via this link), you will be sent a download link for the GA release (2.3.0.328). The trial email and Support Portal will both get you the same executable. If you have already activated Sencha Test with a full license, you will be fully activated with this new version.
    Daniel Gallo
    Senior Solutions Architect
    Sencha Inc.

  3. #3
    Sencha - Sales Team daniel.gallo's Avatar
    Join Date
    Apr 2009
    Location
    Redwood City, CA
    Posts
    326
    Answers
    49

    Default

    Sencha Test 2.3 is now available for download via the Support Portal. Apologies for the delay.
    Daniel Gallo
    Senior Solutions Architect
    Sencha Inc.

  4. #4
    Sencha Premium Member
    Join Date
    Oct 2013
    Posts
    16

    Default

    I had the same issue last week, and tried to download it again today. Now there seems to be another issue when visiting the download page: The loading screen freezes forever, and I see this in dev-tools:

    Uncaught RangeError: Maximum call stack size exceeded
    at ctor.findRelease (app.js?_dc=20190617171332:1)
    at ctor.findRelease (app.js?_dc=20190617171332:1)
    at ctor.findRelease (app.js?_dc=20190617171332:1)
    at ctor.findRelease (app.js?_dc=20190617171332:1)
    at ctor.findRelease (app.js?_dc=20190617171332:1)
    at ctor.findRelease (app.js?_dc=20190617171332:1)
    at ctor.findRelease (app.js?_dc=20190617171332:1)
    at ctor.findRelease (app.js?_dc=20190617171332:1)
    at ctor.findRelease (app.js?_dc=20190617171332:1)
    at ctor.findRelease (app.js?_dc=20190617171332:1)

    I already cleared cookies & browser cache, behaviour is still the same.

    Regards, Werner

  5. #5
    Sencha User
    Join Date
    Mar 2017
    Posts
    45

    Default

    I cannot use the latest ST version 2.3.0.328. I'm receiving the following error log as soon as the application opens and loads my last opened WebDriver based project. This same project runs fine on ST version 2.2.1.83. Any suggestions or need additional information?

    1 0:00:00.133 [INF] Version 2.3.0.328 (Build date 09/09/2019)
    2 0:00:01.999 [INF] Parking Lot open on port 8800
    3 0:00:02.319 [INF] [INFO] [archive/Server] Archive server listening on port 1983
    4 0:00:02.853 [INF] Sencha Cmd v6.5.3.6
    5 0:00:06.147 [INF] Configuration property changed. Reloading build environment state.
    6 0:00:06.148 [INF] Started Sencha Cmd Server with instance id: ae940105-7296-49c5-9740-15d65324f7a7
    7 0:00:06.148 [INF] Starting Sencha Cmd RPC Service at port 1900
    8 0:00:06.776 [DBG] environment: orion (tern v6.0.15)
    9 0:00:08.006 [DBG] found config.json at C:\Workspaces\locumsmart\LocumsMart\LocumsMart\LocumsMartClient\.sencha\ide\config.json
    10 0:00:08.010 [DBG] contents:
    11 0:00:08.011 [DBG] {}
    12 0:00:08.013 [DBG] include [ 'C:\\Workspaces\\locumsmart\\LocumsMart\\LocumsMart\\LocumsMartClient',
    13 0:00:08.013 [DBG] 'C:\\Program Files\\Sencha\\Test\\2_3_0_328\\resources\\app.asar\\node_modules\\orion-core\\serve' ]
    14 0:00:08.031 [DBG] Descriptor file is app.json
    15 0:00:08.051 [ERR] C:\Program Files\Sencha\Test\2_3_0_328\resources\app.asar\node_modules\sencha-tern\plugin\ext\lib\config.js:404
    16 0:00:08.055 [ERR] classpath.forEach(function(classpathEntry){
    17 0:00:08.056 [ERR] ^
    18 0:00:08.056 [ERR] TypeError: classpath.forEach is not a function
    19 0:00:08.057 [ERR] at populateAdditionalInfo (C:\Program Files\Sencha\Test\2_3_0_328\resources\app.asar\node_modules\sencha-tern\plugin\ext\lib\config.js:404:19)
    20 0:00:08.057 [ERR] at findToolkit (C:\Program Files\Sencha\Test\2_3_0_328\resources\app.asar\node_modules\sencha-tern\plugin\ext\lib\config.js:383:27)
    21 0:00:08.058 [ERR] at createApp (C:\Program Files\Sencha\Test\2_3_0_328\resources\app.asar\node_modules\sencha-tern\plugin\ext\lib\config.js:328:30)
    22 0:00:08.058 [ERR] at findApps (C:\Program Files\Sencha\Test\2_3_0_328\resources\app.asar\node_modules\sencha-tern\plugin\ext\lib\config.js:291:19)
    23 0:00:08.059 [ERR] at Array.forEach (native)
    24 0:00:08.059 [ERR] at initialize (C:\Program Files\Sencha\Test\2_3_0_328\resources\app.asar\node_modules\sencha-tern\plugin\ext\lib\config.js:97:51)
    25 0:00:08.059 [ERR] at module.exports (C:\Program Files\Sencha\Test\2_3_0_328\resources\app.asar\node_modules\sencha-tern\plugin\ext\lib\config.js:83:12)
    26 0:00:08.060 [ERR] at Object.postReset (C:\Program Files\Sencha\Test\2_3_0_328\resources\app.asar\node_modules\sencha-tern\plugin\ext.js:120:31)
    27 0:00:08.060 [ERR] at Object.signal (C:\Program Files\Sencha\Test\2_3_0_328\resources\app.asar\node_modules\sencha-tern\lib\signal.js:28:49)
    28 0:00:08.060 [ERR] at Object.reset (C:\Program Files\Sencha\Test\2_3_0_328\resources\app.asar\node_modules\sencha-tern\lib\tern.js:154:12)
    29 0:00:08.105 [ERR] Task "Code Completion Service" <br> exited with code : 1

  6. #6
    Sencha - Sales Team daniel.gallo's Avatar
    Join Date
    Apr 2009
    Location
    Redwood City, CA
    Posts
    326
    Answers
    49

    Default

    Assuming you still have 2.2.1 installed, can you try creating a new blank project using 2.2.1, then close 2.2.1 and open 2.3. It should open the new blank project after launch - does that also throw the same error?

    After you receive the error above, has the application crashed and no longer responds to interactions?
    Daniel Gallo
    Senior Solutions Architect
    Sencha Inc.

  7. #7
    Sencha User
    Join Date
    Mar 2017
    Posts
    45

    Default

    I do not receive the failure in 2.3 when opening the new project I created in 2.2.1. I've tested a few other sample projects in 2.3 and they all open without error so it seems to be isolated to my specific automation project. I receive the above error as soon as ST 2.3 opens my main project and begins to load everything. It does not freeze or crash and I can execute my tests but they are quite a bit slower than 2.2.1. Simple tasks such as clicking a Login or Save button or attempting to type text into a field that is below the page break no longer occur (previous version places focus on the field which scrolls the page down). The future just times out and fails the test. All of these things still work in 2.2.1.

    A little more about my specific project
    ExtJs version 6.5.3
    The project is built using Cmd version 6.5.3.6
    The project has a mix of:
    WebDriver & In-Brower tests but I primarily write WebDriver test
    Classic & Modern ExtJs
    Leverages a global namespace as suggested here: https://www.sencha.com/forum/showthr...obal-namespace



    Attachment 58098

  8. #8
    Sencha - Sales Team daniel.gallo's Avatar
    Join Date
    Apr 2009
    Location
    Redwood City, CA
    Posts
    326
    Answers
    49

    Default

    Are you able to share the contents of your "app.json" file? If you don't want to post it here, feel free to email it to me at [email protected]. The process that is failing is the code completion service - something in that particular project is causing it to throw an unhandled error.

    Regarding the button click - there is a known issue in 2.3.0 (issue id ORION-2576) where "click" methods aren't being executed on some components in a WebDriver scenario unless x/y coordinates are specified as part of the "click" method, e.g. ".click(3, 3)". This may be the same issue you are running in to. You can verify that by adding x/y coordinates to a few of your "click" usages, to see if that resolves the issue. This will be fixed in an upcoming release. For now, you could either add coordinates, or temporarily revert back to using 2.2.1.
    Daniel Gallo
    Senior Solutions Architect
    Sencha Inc.

  9. #9
    Sencha User
    Join Date
    Mar 2017
    Posts
    45

    Default

    Email sent. I'll try the coordinates real quick but may just revert back to 2.2.1 for the time being. Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •