Running the Upgrade advisor over a small part of my codebase, I got this warning:

Usage of private config 'displayField' found for 'Ext.form.field.ComboBox'
This is for advising going from 6.5.2 to 7.0.0 (the Classic framework)

The relevant code looks a bit like:

Code:
{ xtype:'combobox',
  fieldLabel:'Type',
  store: Ext.create('Ext.data.Store',{
    fields:['name'],
    data :[ /*...*/ ]
  }),
  queryMode:'local',
  displayField:'name',
  valueField:'name'
}
The problem is that `displayField` is not private in either 6.5.2 or 7.0.0.