Results 1 to 2 of 2

Thread: Ext is not defined by using Visual Studio 2019

  1. #1
    Sencha User
    Join Date
    Feb 2010
    Posts
    11

    Default Ext is not defined by using Visual Studio 2019

    Hi all:
    I use Visual Studio 2019 to create react app project, and I want to use Extreact. but it will ocurs "Ext is not defined" error.
    follow is my create project step:
    1. Create asp.net core web application with React.js and Redux.
    11-14-2019 5-30-19 PM.png

    2. Open node.js cmd, go to project folder(\ClientAPP folder), run follow cmd.
    npm install --save @sencha/ext-react npm install --save @sencha/ext @sencha/ext-modern @sencha/ext-modern-theme-material
    npm install --save-dev @sencha/ext-react-webpack-plugin @sencha/ext-react-babel-plugin html-webpack-plugin

    11-14-2019 5-35-14 PM.png

    3. after install success, I change index.html and change my app.js like follow:
    Code:
    import React, { Component, Fragment } from 'react';
    import { ExtReact } from '@sencha/ext-react';
    import { Panel } from '@sencha/ext-modern';
    
    
    //==
    //import { Component } from 'react';
    //import React from 'react';
    //const Component = React.Component;
    
    
    class App extends Component
    {
    	render()
    	{
            return (
                <Fragment>
                    <div>Hello</div>
                    <button>Sub</button>
                </Fragment>
    		);
    	}
    }
    
    
    export default App;
    then it will get error.
    11-14-2019 5-38-29 PM.png


    do I miss something?

  2. #2
    Sencha User
    Join Date
    Jul 2017
    Posts
    7

    Default

    Nobody from Sencha will help you here. At most, you can (if you have purchased support) open a ticket on their support platform and they might answer, but this forum is helpless.

    It is not enough only by adding the @sencha dependencies to your project for it to work. You need to change your WebPack configuration in order to include the ExtReact plugin, and probably Babel configuration in order to use the ExtReact plugin, as well.

    You can refer to this guide: https://docs.sencha.com/extreact/7.0...ext_react.html

    Which is not very extensive. But I have spent a myriad hours updating a create-react-app app with ExtReact from 6.5.3 to 7.0.0 and from React15.8 to 16.11, so I might be able to help you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •