Results 1 to 3 of 3

Thread: 7.1 sencha upgrade will not work

  1. #1
    Sencha Premium Member
    Join Date
    Aug 2013
    Location
    Australia
    Posts
    493

    Default 7.1 sencha upgrade will not work

    c:\CB\apps\71>sencha upgrade
    Sencha Cmd v7.0.0.40
    [INF] Determining the latest version of Sencha Cmd
    [INF] Downloading : ....................
    [INF] The latest version of Sencha Cmd is 7.1.0.16
    [INF] Downloading SenchaCmd-7.1.0.16-windows-64bit.zip from http://cdn.sencha.com/cmd/7.1.0.16/jre/ to temp folder C:\Users\selvy\AppData\Local\Temp\sencha1579136317475
    [INF] Cleaning up temporary files in C:\Users\selvy\AppData\Local\Temp\sencha1579136317475
    [ERR] Error downloading http://cdn.sencha.com/cmd/7.1.0.16/j...dows-64bit.zip

    http://cdn.sencha.com/cmd/7.1.0.16/j...dows-64bit.zip --> 404 Not Found


    Going to "Getting Started with Cmd" (https://docs-devel.sencha.com/extjs/..._with_cmd.html)
    there is a link (Free - Download Sencha Cmd) to 7.1 Cmd (https://www.sencha.com/products/extjs/cmd-download/)
    This gives 7.1.0.15 Cmd zip file that can be decompressed and executed.
    then upgrade ext-gen: npm install -g @sencha/ext-gen
    then create app: ext-gen app -i


    ENOENT: no such file or directory, open 'c:\CB\apps\package.json'


    Starting with WebStorm --> works with Chrome Console warnings

    A cookie associated with a cross-site resource at http://kaspersky-labs.com/ was set without the `SameSite` attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with `SameSite=None` and `Secure`. You can review cookies in developer tools under Application>Storage>Cookies and see more details at https://www.chromestatus.com/feature/5088147346030592 and https://www.chromestatus.com/feature/5633521622188032.
    bootstrap.js:2350 [Deprecation] Application Cache API use is deprecated and will be removed in M82, around April 2020. See https://www.chromestatus.com/features/6192449487634432 for more details.
    checkForAppCacheUpdate @ bootstrap.js:2350
    checkAllUpdates @ bootstrap.js:2339
    onAllAssetsReady @ bootstrap.js:2280
    notify @ bootstrap.js:1199
    processLoadedEntries @ bootstrap.js:1178
    notifyRequests @ bootstrap.js:1655
    complete @ bootstrap.js:1504
    (anonymous) @ bootstrap.js:1507
    el.onload @ bootstrap.js:1414
    load (async)
    createLoadElement @ bootstrap.js:1413
    loadElement @ bootstrap.js:1506
    load @ bootstrap.js:1563
    loadEntries @ bootstrap.js:1139
    processRequest @ bootstrap.js:724
    load @ bootstrap.js:746
    onCachedAssetsReady @ bootstrap.js:2264
    load @ bootstrap.js:2228
    setManifest @ bootstrap.js:2169
    (anonymous) @ bootstrap.js:2141
    readyStateChange @ bootstrap.js:854
    XMLHttpRequest.send (async)
    window.XMLHttpRequest.send @ main.js?attr=_CPr5wFysrHbYx8QXP2Pi6nqsXyIkZeRIfv4RzzSWxHISJ3K6_zFm5T49DJW1nKD:1050
    fetch @ bootstrap.js:868
    run @ bootstrap.js:2140
    (anonymous) @ bootstrap.js:2698
    MainViewController.js?_dc=1579141538927:33 Store not yet available from viewModel binding

  2. #2
    Sencha Premium Member
    Join Date
    Aug 2013
    Location
    Australia
    Posts
    493

    Default

    Tried again today 17/1/20
    sencha upgrade works in that it takes my 'Sencha Cmd v7.1.0.15' as the latest version.

    Still one moderate error in the ext-gen app -i

    C:\CB\apps\71\my-app-3>npm audit


    === npm audit security report ===




    Manual Review
    Some vulnerabilities require your attention to resolve


    Visit https://go.npm.me/audit-guide for additional guidance




    Moderate Regular Expression Denial of Service


    Package marked


    Patched in >=0.6.2


    Dependency of c05330e21985bb6c30157a12fe12bdaf4ed114269fa2ea980db2132f529…
    [dev]


    Path c05330e21985bb6c30157a12fe12bdaf4ed114269fa2ea980db2132f529…
    > switchit > marked


    More info https://npmjs.com/advisories/812


    found 1 moderate severity vulnerability in 15431 scanned packages
    1 vulnerability requires manual review. See the full report for details.

  3. #3
    Sencha Premium Member
    Join Date
    Aug 2013
    Location
    Australia
    Posts
    493

    Default

    consider fixed, except for moderate vulnerability

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •