Results 1 to 5 of 5

Thread: ComboBox loses user choice after focus goes elsewhere.

  1. #1
    Ext User
    Join Date
    Jan 2009
    Posts
    28
    Vote Rating
    0
      0  

    Question ComboBox loses user choice after focus goes elsewhere.

    I copied a tutorial from a book showing how to generate a form, and one of the elements of the form was a combobox. I was able to generate the elements of the list of choices through JSON and WCF (as opposed to php used in the tutorial), but the combobox is behaving strangely. After choosing an item from the list, it appears in the combobox - as expected. But as soon as I click away from the combobox, my selection disappears making the combobox look like no selection was made.

    Any ideas?

    The relevant code:

    Code:
    var genreStore = new Ext.data.Store({
                reader: new Ext.data.JsonReader({
                    fields: ['id', 'genre_name'],
                    root: 'rows'
                }),
               proxy: new Ext.data.HttpProxy({
                    url: 'Service1.svc/getDropdown'
                })
    
            });
    ...
    ...
    var movie_form = new Ext.FormPanel({
                    url: 'Service1.svc/InsertRow',
                    renderTo: document.body,
                    frame: true,
                    title: 'Movie Info Form',
                    width: 250,
                    items: [{...
    ...
    xtype: 'combo',
                        name: 'genre',
                        fieldLabel: 'Genre',
                        mode: 'local',
                        store: genreStore,   //for locally supplied data use 'genre', not 'genreStore'
                        displayField: 'genre_name',
                        width: 120,
                        selecOnFocus: true,
                        forceSelection: true,
                        autocomplete: true,
                        triggerAction: 'all'
    ...

  2. #2
    Sencha User jay@moduscreate.com's Avatar
    Join Date
    Mar 2007
    Location
    DC Area =)
    Posts
    16,364
    Vote Rating
    87
      0  

    Default

    what version of Ext is this occurring in ?

  3. #3
    Sencha User jay@moduscreate.com's Avatar
    Join Date
    Mar 2007
    Location
    DC Area =)
    Posts
    16,364
    Vote Rating
    87
      0  

    Default

    also, browser/os?

  4. #4
    Ext User
    Join Date
    Jan 2009
    Posts
    28
    Vote Rating
    0
      0  

    Default Hi JGarcia!

    Well, I'm using version EXT2.2,and my OS is Vista Professional. FF3 is my browser. Do you need further details?

    Thanks for your attention,
    D.

  5. #5
    Sencha User
    Join Date
    Nov 2010
    Posts
    7
    Vote Rating
    0
      0  

    Default

    Was this ever resolved?
    I have the same issue now. Ver 3.3.2.
    Firefox Browser.

    Thanks
    Andrew

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •