Results 1 to 6 of 6

Thread: [2.2.1] Bad width for toolbar buttons on IE8 in "EmulateIE7" mode

  1. #1
    Ext User pbuyle's Avatar
    Join Date
    Mar 2008
    Location
    Belgium
    Posts
    32
    Vote Rating
    0
      0  

    Default [2.2.1] Bad width for toolbar buttons on IE8 in "EmulateIE7" mode

    When using toolbar buttons with text in a page with containing
    HTML Code:
    <meta http-equiv=\"X-UA-Compatible\" content=\"IE=EmulateIE7\" />
    to force IE8 in compatibility mode, buttons with text have w additional width at the left and right (the exact amount seems the depends on the button's text), see attached screenshot. Buttons have the correct width when the compatibility mode is activated manually on a page without the X-UA-Compatible meta tag.

    And yes, it seems that ''Compatibility mode'' != ''EmulateIE7'', see http://blog.pengoworks.com/index.cfm...and-EmulateIE7
    Attached Images Attached Images

  2. #2
    Sencha User
    Join Date
    Jun 2007
    Posts
    33
    Vote Rating
    0
      0  

    Exclamation [2.2] Bad width for toolbar buttons on plain IE7, too

    I'm also now seeing this problem on plain old IE7 and Ext 2.2. Maybe I've got an updated IE7. My version is 7.0.5730.13.

    Most of my pages are okay with the wider buttons, but I've got one that is causing real problems.

  3. #3
    Sencha User evant's Avatar
    Join Date
    Apr 2007
    Location
    Sydney, Australia
    Posts
    18,988
    Vote Rating
    934
      0  

    Default

    Is this in quirks or strict mode?
    Twitter - @evantrimboli
    Former Sencha framework engineer, available for consulting.
    As of 2017-09-22 I am not employed by Sencha, all subsequent posts are my own and do not represent Sencha in any way.

  4. #4
    Sencha User daniel_82's Avatar
    Join Date
    Feb 2009
    Posts
    31
    Vote Rating
    0
      0  

    Default

    I got the same problem.
    Anyone got the solution yet?

  5. #5
    Ext User
    Join Date
    Dec 2008
    Posts
    2
    Vote Rating
    0
      0  

    Default Also experiencing issue.

    I am experiencing the exactly same issue. Browser Mode: IE8 Document Mode: IE7 Standards. IE7 looks fine. Still looking for a resolution.

  6. #6
    Sencha User Condor's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    24,246
    Vote Rating
    128
      0  

    Default

    I'm using this workaround.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •