Results 1 to 4 of 4

Thread: EXT GWT backward compatibility

  1. #1
    Ext User
    Join Date
    Dec 2009
    Posts
    1
    Vote Rating
    0
      0  

    Default EXT GWT backward compatibility

    Hi,

    Is GWT 2.0 backward compatible with 1.x?

  2. #2
    Sencha User
    Join Date
    Aug 2008
    Posts
    226
    Vote Rating
    2
      0  

    Default

    there are changes that need to be done but it shouldnt be that hard. most features are still there.

  3. #3
    Ext GWT Premium Member
    Join Date
    Mar 2007
    Location
    Houston, TX
    Posts
    14
    Vote Rating
    0
      0  

    Default

    Code written in 1.6/1.7 will compile without problem in GWT 2.0

    Code written to take advantage of new 2.0 features (RunAsync, ResourceBundle, etc...) will obviously not compile in 1.X

    Tony

  4. #4
    Sencha User darrellmeyer's Avatar
    Join Date
    May 2007
    Location
    Washington, DC
    Posts
    2,242
    Vote Rating
    2
      0  

    Default

    Ext GWT 2.1 is compatible with GWT 2.0. We have been monitoring the earlier releases of GWT 2.0 to making to ensure the Ext GWT code worked with GWT 2.0.

    However, there is one change that you will need to make to use GWT 2.0. See the following post which describes the change you will have to make to run GWT 2.0 with GXT 2.1.

    Ext GWT 2.X will continue support for both GWT 1.7 and GWT 2.0. Ext GWT 3.0 will only support GWT 2.0+ and will take advantage of the new features in GWT 2.0.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •