Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Ext User
    Join Date
    Mar 2010
    Posts
    1
    Vote Rating
    0
    faycal.inajjarane is on a distinguished road

      0  

    Default [CLOSED] Ext Designer Crashes on Windows XP

    Hi,
    I just installed Ext Designer on my win XP and it crashes too. Here is the error signature:

    AppName: ext designer.exe AppVer: 0.0.0.0 ModName: qtcoreext4.dll
    ModVer: 4.6.1.0 Offset: 00095227
    I don't know if it's happends only for the trial version!
    Any Idea for fixing this issue?

  2. #2
    Sencha User aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,486
    Vote Rating
    139
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default

    When does it crash? Do you see the login screen?

    Did you login? Did the application launch?
    Aaron Conran
    @aconran

  3. #3
    Ext User
    Join Date
    Oct 2009
    Posts
    2
    Vote Rating
    0
    aowken is on a distinguished road

      0  

    Red face same same

    i can see login screen. crash when click "continue trial"

  4. #4
    Sencha User aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,486
    Vote Rating
    139
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default

    Not sure how your install has become corrupted. Take the following steps to see if it helps you. Search for and delete the "Ext Designer.ini" file.

    Relaunch the designer, you will see a prompt that you have a corrupted install and need to restart. Restarting will download the latest version of the xds ion file.
    Aaron Conran
    @aconran

  5. #5
    Ext User
    Join Date
    Oct 2009
    Posts
    2
    Vote Rating
    0
    aowken is on a distinguished road

      0  

    Default thx

    resolved! thx

  6. #6
    Ext User
    Join Date
    Oct 2009
    Posts
    2
    Vote Rating
    0
    knapejor is on a distinguished road

      0  

    Default

    I'm having this problem too, with the registered version. I deleted the ini as described, but now Ext Designer just doesn't show up. (the process is started, as I can see it running in the task manager)

    Any ideas on this?

  7. #7
    Ext User
    Join Date
    Oct 2009
    Posts
    2
    Vote Rating
    0
    knapejor is on a distinguished road

      0  

    Default

    I uninstalled, and cleaned the registry of all ExtDesigner items, re-installed and updated the Designer, now it all seems fine again..

  8. #8
    Sencha User
    Join Date
    Apr 2009
    Location
    Australia
    Posts
    4
    Vote Rating
    0
    nickweedon is on a distinguished road

      0  

    Default This exact issue is also occurring for me on Windows 7 (32 bit)

    I have the same issue as reported by the other people.

    Notable Hardware:
    - Running on a hi res television, 1920 x 1080.
    - Using non-standard 'display settings' text size (medium 125%).
    - Nvidia GPU

    Operating System:
    - Windows 7 (32 bit) with service pack 1

    Sencha Architect Version:
    - 3.1.0 Build 1943

    Workarounds attempted:
    - Could not perform: Delete 'Ext Designer.ini' - I could not find any .ini files in any of the Sencha directories.
    - Uninstalled Sencha architect and then deleted residual files from '%USERPROFILE%/AppData/Local/Sencha/...' and 'Program Files/Sencha...' and also removed all traces from the registry, then re-installed.
    - Tried running in compatability mode and all reasonable options in the shortcut's 'compatibility mode tab'.

    Steps to reproduce (precondition: a trial user account has been created):
    - Launch Sencha Architect from the desktop shortcut.
    - The Sencha Architect application is launched and presents a screen showing the evalution period remianing and a 'Continue' button.
    - Click on the continue button.
    - Nothing happens, although the process explorer shows 3 sencha architect processes running, these processes terminate shortly after.

    An alternative scenario to this is that the project screen does actually appear but crashes shortly after.

    I have noticed also that if i wait for a long time (at least 30 seconds) then click on continue, it will work although I havn't done this enough times at this stage to confirm that this behavior is in any way deterministic.

    Perhaps this issue is some kind of race condition?

  9. #9
    Sencha User
    Join Date
    Apr 2009
    Location
    Australia
    Posts
    4
    Vote Rating
    0
    nickweedon is on a distinguished road

      0  

    Default Update: Definitely a race condition, workaround discovered.

    Update
    • This is definitely a race condition as it is reproducible 100% of the time for me when clicking 'continue' immediately and yet it happens 0% of the time when waiting for at least 30 seconds before clicking 'continue'.
    • It may be useful to know that I use a solid state hard drive on the machine that I develop on (in case this is affecting startup load timing).
    Workaround
    Simply wait for approximately 30 seconds before clicking the 'continue' button.